Citrix Environment Selector Issues

I am working with a Citrix environment where we are unable to use the plugin. When I set up my selectors I am hitting F3 and highlighting the images and validation is always at 100% when I pick my selectors

I ran it last night on 100 tasks and didnt have any real issues outside adjusting some selectors on things that have a little variability. This morning I ran it on 20 more with no issue.

This afternoon I start it, and it keeps giving me “Unable to find the UI element” on the very first activity. Nothing I did fixed it. Finally I did a hard reboot and then it was working and finding it again.

After about 20 tasks however its randomly in the middle of the flow started giving me an unable to find UI element. I stopped the flow, redid the selectors and its still telling me 100% validation. But when running it again it fails everytime.

This isnt the first time its happened and I always thought I just needed to adjust my selectors but this one hasnt failed in over 150 runs and now is failing and there is literally no variability to the image/anchor to throw it off. Side note this is on the same program that other activities interact with with no issue. All selectors were set up the same. So if it was a window name change or something wouldn’t it effect all of the activities clicking on the same window? Any ideas why this one random activity is failing

Any suggestions?

Hey! @guruice4

Why can’t we add some delay? and change the WaitForReady->Complete…

Add the delay between keys
Add the delay before and after


  1. The website which you’re working is slow at loading
  2. The speed of the robot may fast
  3. Internet connection is not good

Just add the delay and try to run it again…

If the issue is not resolved will check with the alternative way


1 Like

Hello @guruice4

Whenever its failing can you check the memory utilization in the citrix? Is there any parallel process executing during the time windows where you are executing the UiPath?

If the process is working fine sometimes and failing randomly, then you need to check the memory utilization and need to provide enough delay to the activities. Better to give more timeout, it can fix the issue.

1 Like

Thanks! I think you were both correct, adding some delay seemed to work.

I was also using keyboard commands (Escape) when I removed that it seemed to fix it.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.