SAP GUI click text not working

Hello, I am trying to automate SAP GUI. I am unable to click “Connections” shown in the image below (Note, I do not have the correct access to run transaction RZ11) so I have tried using click text to click “Connections”. This also did not work and it kept selecting the top left corner…How do I get this to work?

I have also attached my workflow for this.GUI Test.xaml (8.2 KB)

Hi,
I assume that you only have explorer view in your SAP GUI 7.50 so you can’t use List view?
You can try using click image instead, and indicate the scope to be just the section highlighted in blue in your Screenshot.

Capture

Hi @Hisuhong,

Check if SAP scripting is enabled or not.
It should be enabled to get the selectors from SAP GUI and in ui explorer change ui frameworks to Active Accessibility to get all possible selectors.

Thanks

Refer below links to enable SAP GUI scripting, create reliable SAP GUI automation

1 Like

@Krishna_547 I do have scripting allowed. It’s just this initial screen that is giving me issues. Once I login, click text works really well (and without OCR)

I can also type into the appropriate fields and click buttons so it’s just selecting the connections that is giving me problems

Try Keeping Ui Frameworks as DEFAULT in UI Explorer while getting the selector,

HI,

SAP Logon does not use SAP scripting interface. This is like a normal Windows Apps.

Is there any use case to make extensive automation of SAP logon?

Lev

That also does not work unfortunately :cry:

Hello,

I am trying to create an unattended automation for GUI and I need to get past this logon screen :cry:
I am fine with everything except for selecting Connections… Click OCR text is not working so I am unsure what to do

@Hisuhong

Did you try give click on image a try yet? remember to grab just the connection as the image and specify the scope to be the left window, you may have to tweak the Accuracy setting in click image as well as you needed.
I had this issue before as well before we upgraded to SAP GUI 7.60

Hi @Johno,

I just tried Click Image but it clicks the wrong “Connections” (The one circled in red in the image below)


I tried to tweak the accuracy but it’s still giving me the same issue :cry:

@Johno never mind, I got it to work. Thank you for helping me out everyone! :smiley:

@Hisuhong please share the solution with the community!

@LevKushnir Ah okay. I forgot to post my solution (^ᗜ^)
When I dragged and dropped the Click Image activity into my workflow, it did not capture the selector for the “Connections” I wanted, so it ended up selecting the “Connections” at the top.
So what I then did was go to “Recording” (Basic) and used Click Image from there


This captured the selector of the “Connections” I wanted. (ノ◕ヮ◕)ノ*:・゚✧

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.