Enable SAP GUI Scripting doesn't work

Hello,

I want to enable the SAP GUI Scripting to optimize the development in SAP.

So, I follow the guide below:

That 2 flags are already enabled but the result with UI elements in SAP is the same. I still cannot click on a specific cell of a table or something like that.

I already contacted the SAP GUI team and they told me that flag in server side is enabled.

Anyone can help me please?

Is this issue only with table element or will that apply for even buttons and drop downs.? Because sometimes in few of pages in SAP versions below 740 its difficult to find selectors, try once by using Uiexplorer(Sometimes works which wont work with activities).

Hi @Divyashreem

My SAP version is the 7.5 PL7.

For even buttons (as you can see in the image below) I can’t pick one.

Any sugestion? Maybe it’s a security permission idk?

no clue other than enabling script on both sides

  1. Click Customize Local Layout, and then click Options.
  2. Click Accessibility & Scripting, and then click Scripting.
  3. Check the Enable scripting box.
  4. Click OK.

Above points will helps you to enable SAP GUI Interface.

Hi @FranciscoAraujo,

Double check if

  1. The Rz11 has been enabled properly
    Sap%20Scripting%20not%20enabled
  • In my example when i hover the mouse on the right of the OVR text. i get the an indicator saying scripting support is disabled on the server

  • Gui scripting won’t work even if enabled on the SAP client if the RZ11 is not set

  • Check if the RZ11 was enabled on the correct environment eg Dev Environment, production etc. usually there is a miscommunication here

  1. Keep the patches up to date
  • Assuming you are on version 750 Patch 7 is sufficient. in fact patch 4 is sufficient but i highly recommend you go up to patch 11 if possible.

Let me know how it goes.

Regards
Malik
Eguardian

Hi!

Now it’s working fine.

I think the problem was the SAP version that I was using. We have to change to SAPlogon.exe and now it’s working with all this settings that you said.

Thank you,
Francisco

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.