Running UiRobot in RDP using Orchestrator

Hi everyone,

Whenever I run my workflow in RDP using Orchestrator, timeout error keeps on popping up. I have done some research on this and none of the solution given was able to solve the issue.

Steps by step of my execution:

  1. Log in to RDP.
  2. Run UiPath Robot. (Make sure it is properly connected to Orchestrator)
  3. Disconnect from the RDP. (Use “Disconnect” instead of “sign out” as the robot will be disconnected from the Orchestrator if sign out)
  4. Run the job from orchestrator on local machine.

The wokflow does not give timeout error if I run the robot using Orchestrator from inside the RDP session and stay connected.

Thank you in advance

1 Like

Welcome to uipath community
I think the bot is not able to find the element and that’s why showing error as timeout
—Make sure that we have used MAXIMIZE window activity as a first activity in the sequence so that the window is not minimised this ensuring not can look into the elements
—and also check with the properties of click or type into activity like Simulate click and simulate type property in the property panel

Kindly try this and let know for any queries or clarification
Cheers @husnirahman

Hi Palaniyappan,

  • I have tried adding the maximizing window activity but the error persists. Moreover, wouldn’t it show the “UI Element not found error” if it’s not able to find the element?

  • I did not use simulate type because it does not work with the application/workflow that I am using.

Thank you for your suggestion