Scheduled task is starting but giving a timeout error - RDP session problem


I am scheduling a job via Orchestrator to run a simple robot that opens the browser, clicks a couple of html elements and closes the browser. When the robot runs on scheduled time while the screen is locked, it fails with Timeout reached error, and when I log in to the computer I see that the browser window was opened but none of the ui element clicking actions were performed. I suspect the problem might be with the RDP session not initializing. If I run the robot locally, or via Orchestrator with unlocked screen, everything completes successfully. What might be the problem?

For the click activities, have you tried using the ‘Simulate Click’ option? Using this option allows you to perform the clicks in the background. Try using that option and see whether it works.

Thanks for your suggestion,

Tried the simulate click option, but it is not supported by the desktop application that I am automating.

Hi there, I am running into same situation. Were you able to resolve it? Would you be kind to share the solution and how you resolved it. Thanks a lot.

Hello Akim,

Yes, we were able to resolve the problem. The issue was in our corporate firewall blocking the rdp connection that is needed when the orchestrator starts the robots. I recommend setting up the orchestrator and the robots in a testing environment with no local network limitations, and only after extensive testing moving them to prod. servers. That was the approach we used when building our robot.

Thanks for your response back. So, it looks like you were running Robot from public Orchestrator ( and firewall was blocking RDP session - is this correct?
But in my case, it works from Public Orchestrator when RDP session is opened or minimized in my local workstation. So, why firewall does not block then?

We will have tough time opening RDP port in firewall. Did you make any other changes? I greatly appreciate your feedback.