Timeout reached in unattended run

Hi,

I run the automation by using the remote desktop.

The issue is it run perfectly in the vm ( run though the UiPath Assistant and studio, and when the remote desktop is connected)

However, after I signed out from the remote desktop, and run in as unattended from orchestrator. It show the timeout reached.

I tried using the stimulate click and it showed that the “Click with “Simulate” is not supported for this element.”

I installed the service mode

@MVP2022 @MVP2021

Regards,
G_ii

Hi @g_ii ,
Note: Minimizing the desktop window / Login to the Robot server when the process is being executed in unattended mode / Disconnecting the Robot session - It’s not supported.
Also, scheduling jobs using Task Scheduler is not supported.
Please use Orchestrator

Thanks & Regards,
Shubham Dutta

Hi just FYI you can use Send Window Message property. this will probably remove your error
Do let me know if it worked.

Thanks
Vineet

@g_ii
Do you have an unattended bot license?

Hi @Shubham_Dutta @Gokul_Jayakumar @Vineet_Joshi

I do have the unattended bot license.

Previously, I run through the Orchestrator, but it failed.

However, when I tested with the remote desktop signed to view the error ( I opened the remote desktop and run through orchestrator), it doesn’t show the errors. Using the UiPath Assistant also didn’t faced any errors.

Will test the Send Window Message later.

And I wanted to ask is it possible if the selector is works fine in Studio but failed if run through the orchestrator (after publish).
Cause if it is possible, then maybe it’s related to the selector’s issue as the error “Click with “Simulate” is not supported for this element.” is shown after I enable the stimulate click.

Thanks

Hi Bro.

Sometime i have faced this issue also… It still typed text into the textbox, but it still show the error as you faced.

I have used the TryCatch to resolve this issue


2

Hi,

I did used the try catch in my workflow. However, I had another problems faced. That’s one is another story.

I am unable to take the screenshot :

Take Screenshot: System.ComponentModel.Win32Exception (0x80004005): The handle is invalid at System.Drawing.Graphics.CopyFromScreen(Int32 sourceX, Int32 sourceY, Int32 destinationX, Int32 destinationY, Size blockRegionSize, CopyPixelOperation copyPixelOperation) at System.Drawing.Graphics.CopyFromScreen(Point upperLeftSource, Point upperLeftDestination, Size blockRegionSize, CopyPixelOperation copyPixelOperation) at UiPath.Vision.UiImage.FromScreenRegion(Rectangle region) at UiPath.Core.Image…ctor(Region screenRegion)

Both my error only occurs when I run through Orchestrator, It didn’t faced errors when I run though the UiPath Assistant.

PS:
I did have the

  1. unattended license
  2. robot is in service mode
  3. LogintoConsole is enabled and set to No
  4. The screen resolution is set already

And now I do not sure whether it is the issue is because of the dependencies or what…
And also not sure whether the timeout reached error is because of what…
But wanted to fix the timeout reached problem in this forum that I created.

Regards,
G_ii

Hi Bro.

I suggest you try to upgrade or downgrade some packages as attached and try again.

@g_ii
Maybe resolution issues happen, kindly check it.
How do you set the screen resolution for a UiPath robot? - Stack Overflow.

My problems is still unable to resolve. Currently, thinking to recreate a new workflow and see whether is workflow’s problems. However, this will takes some time. Thus I will just left the problem here, and will update after that.