Activity Timeouts, Can't Stream robot machine

Hi i have couple of problems. We are using cloud.uipath as orchestrator. Robots all connected and licensed. I can run jobs. But;

  1. When a simple job(like open browser, click somewhere) started via orchestrator, job fails in 30 seconds with activity timeout exception. Robot opens browser, then doesn’t type into.

image

  1. I used this component before: https://connect.uipath.com/marketplace/components/robot-streaming

2 machines in same domain can stream to each other. When i connect those 2, i can see the stream. When i disconnect one of them, streaming stops.(I think its about problem 1)

I checked resolution problems.

Found this;
https://social.technet.microsoft.com/Forums/sqlserver/en-US/0dd103cc-0da3-4d78-9a79-7aaf8598184c/using-remotedesktopsuppresswhenminimized-for-a-nested-rdp-session?forum=winserverTS

Tried but i got nothing.

So i think when i disconnect on robot machine, rdp seems “minimized”. There could be a policy problem. Does anyone get these before?

PS. Studio and robot working in same machine. I can run that job with studio perfectly.

Thanks for your answers!

Please check system event viewer after running jobs from orchestrator and share event log, it will help in understanding root cause of this problem

How can i take the event log about this job?

Not for Job, but you have to go to windows log, do a refresh and look for services by orchestrator.

Setresolution: Error updating screen resolution.

Did you set resolution of Robot on orchestrator.

Yes, changed uipath.settings file too.

This is causing problem, if possible, change it to default and try to run it.

Also,

ResolutionWidth The machine’s display resolution width. This option is set to 0 by default, which means that it automatically retrieves and uses the detected resolution width. You can use a custom value, as long as it is supported by the workstation.
ResolutionHeight The machine’s display resolution height. This option is set to 0 by default, which means that it automatically retrieves and uses the detected resolution height. You can use a custom value, as long as it is supported by the workstation.
ResolutionDepth The machine’s display resolution depth. This option is set to 0 by default, which means that it automatically retrieves and uses the detected resolution depth. You can use a custom value, as long as it is supported by the workstation.

Could you check if this resolution is supported by machine or not.
Also, share uipath.seting file

I changed resolution on orchestrator to 0, settings too. In the event viewer we are not getting resolution event. Timeout still exist;

UiPath.Executor 20.4.1.0
UiPath.Core.ElementOperationException: Timeout reached. —> System.Runtime.InteropServices.COMException: Timeout reached.
at UiPath.UiNodeClass.BringIntoView()
at UiPath.Core.UiElement.BringToForeground()
— End of inner exception stack trace —
at UiPath.Core.Activities.TaskAsyncCodeActivity`1.EndExecute(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)
— End of stack trace from previous location where exception was thrown —
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
at UiPath.Executor.BaseRunner.EndExecute(IAsyncResult result)
at UiPath.Executor.InProcessRunner.EndExecute(IAsyncResult result)
at UiPath.Core.Activities.ExecutorInvokeActivity.EndExecute(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager), HResult -2146233088

@Lakshay_Verma

Type Into’s activate property was true. Changed it to false. Now getting an exception like that;

UiPath.Executor 20.4.1.0
UiPath.Core.ElementOperationException: Desktop has been disconnected while performing UI actions. —> System.Runtime.InteropServices.COMException: Desktop has been disconnected while performing UI actions.
at UiPath.UiNodeClass.WriteText(String text, UiInputMethod inputMethod)
at UiPath.Core.UiElement.WriteText(String text, InputMethod method)
— End of inner exception stack trace —
at UiPath.Core.Activities.TaskAsyncCodeActivity`1.EndExecute(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)
— End of stack trace from previous location where exception was thrown —
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
at UiPath.Executor.BaseRunner.EndExecute(IAsyncResult result)
at UiPath.Executor.InProcessRunner.EndExecute(IAsyncResult result)
at UiPath.Core.Activities.ExecutorInvokeActivity.EndExecute(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager), HResult -2146233088

Could you please share Uipath.settings file
And change login to console to Yes and run it.

Tried that and didn’t work.

{
“SecureLicenseKey”:blablabla",
“TracingLevel”: “Information”,
“UiPathServerUrl”: “https://cloud.uipath.com/blablabla”,
“ConnectionString”: “”,
“ActivitiesFeed”: “”,
“NuGetApiKey”: “”,
“NuGetServerUrl”: “%ProgramData%\UiPath\Packages”,
“LowLevelTracing”: false,
“LoginToConsole”: false,
“ResolutionWidth”: 0,
“ResolutionHeight”: 0,
“ResolutionDepth”: 0,
“FontSmoothing”: false
}

Change login to console to TRUE

Like i said tried and didn’t work.

As per this setting file i see it is selected as Login to console: False

Yes i changed false after i tried it was true.

Problem with this is, system gets disconnected when start to do UI Interaction. I am just thinking about what causing it. Is event log changed or is it still same ?

Still same. There would be an issue about logout/locked screen but i don’t know system side.

There is a way to check in, You can install a third part software on your machine.
e.g. Ultraview it work likes Team Viewer.
connect via ultraview from some other system and see what exactly causing this.