"Timeout reached" error when RDP is disconnected

Hi All,

I have been reading a lot of forum posts regarding this issue but could not find one with complete solution. I am still having the problem and hoping for some genuine solution. Please help - but please don’t refer to other posts with no solutions. I greatly appreciate your support.

Problem: Bot stops running when RDP session is disconnected. It opens the browser in remote VM but does not proceed executing the rest of the script.

I am using public Orchestrat (platform.uipath.com) - getting a failure with the following error:

An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is:
UiPath.Core.ElementOperationException: Timeout reached. ----> System.Runtime.InteropServices.COMException: Timeout reached.
at UiPath.UiNodeClass.BringIntoView()
at UiPath.Core.UiElement.BringToForeground()
— End of inner ExceptionDetail stack trace —

Here is I had done so far:

  1. Created RemoteDesktop_SuppressWhenMinimized registry entry in Terminal Server Client and set to value of 2.
  2. Tried “LoginToConsole”: false on UiPath.settings file
  3. in Computer management → local user and group - > Groups-> Remote Desktop user->add the robot account in RDP users

Nothing above resolved the issue. The fact that it opens the browser, it doesn’t look like an issue for public Orchestrator accessing my Robot server. Why Bot does not execute rest of the script after opening the browser when not in RDP. How schedule unattended robot concept works then? I am sure mots of you have already figured this out. Would you please be kind to help me out.

Your advice and solution to this issue would be greatly appreciated.



Buddy @Akimalam

This can be easily sorted out buddy

Did you refer this url buddy…if not we can tweak the workflow a bit more on our own


Did that worked for you buddy @Akimalam

Thanks a lot Palaniyappan for your response. I have gone through some of your suggestions but still no luck. Changed TimeOut to 60000 ms on all activities. Also, tried the WaitForReady to different value. I have created a very simple script for this test (included here) - it opens a browser with www.google.com and search & get current weather and email. When I run having RDP open or minimized, it works fine. When I disconnect, it fails - “timeout” error in Orchestrator log. When I RDP back to the VM server, I see browser got google opened but nothing after that. Would you please try attached script on your’s.

I greatly appreciate your time - looking forward to have a good solution at the end.

Main.xaml (8.4 KB)

I also tried by logging out of the RDP instead of disconnecting by x-ing out. When logged out, Orchestrator Jobs page shows as “pending” - never completes it.

Hi @Akimalam

Could you clarify something for me. Are you connecting an unattended Enterprise locally-licensed robot to the Orchestrator CE?

I am using UiPath’s Orchestrator at “https://platform.uipath.com” which is © UiPath 2019
Orchestrator Community 2019.4.0-CE.22 Community License. Also, the using Development Robot. Should I be using Unattended instead of Development? As far as Robot on my VM install goes, that also is a community version. Waiting to hear from you.

I got an error when creating UnAttended robot - “No available licenses: …”. Does that mean I can’t use RDP being disconnected or logged off with Development robot? If so, is there anyway to get around to it.

Hi @Akimalam

Several things I need to mention here. Basically, the Community Edition of our software (Studio, Robot and Orchestrator) should not be used to schedule unattended processes. This is a result of several technical and legal restrictions.

Orchestrator CE provides 2 Development robot licenses for you to be able to evaluate the software or even run attended automatons in small companies, but it is not designed to automatically log in to a user acccount and run unattended scheduled processes via Orchestrator CE.

1 Like

Thanks a lot for clarifying that. Now it makes sense. Since we are still in evaluation cycle, wanted to try the unattended robot with scheduling. I appreciate your response back.

You would be able to test the unattended automation with the Trial which provides your own custom installer for Orchestrator as well as a Robot that can be installed as a service for the entire machine. It is technically not possible to make Orchestrator CE log in to the user profile on a machine with the Community Edition installed.

1 Like

Thanks for your input. What I don’t understand is - it looks like Orchestrator CE is technically logging into the system ok- not only that, it also opens the browser with proper website. It times out after that. So it looks like there is no issue accessing our server where Robots are being run . Does time-out issue depend on unattended vs development robot? That’s the part I am lost on. Please advise.

The robot service of the Community Edition does not run for the entire machine. This means that logging a user out on the target machine will result in Orchestrator not being able to reach the Robot service (which is terminated upon a log-out).

In your case, the remote machine is most likely already logged in and the Orchestrator is simply able to connect to it. The issue of what happens later is of a different kind.

If you really want to debug it, try saving a screenshot of your remote machine just before it fails.

1 Like