Robot won't license itself when connecting to Orchestrator

When I connect the robot to Orchestrator, it gives the status: Unlicensed at the bottom left of the Orchestrator Settings for the bot.

Hovering over the Status: Unlicensed text shows a pop up: “Robot does not exist.”

The Machine version says Unknown.

Licenses shows 2 of 2 licenses in use, even with the Bot and Studio offline.

I’m using the Community edition, the Studio for which activated fine.

Anyone have an idea as to what might be going on here?

1 Like

Hi
Welcome to UiPath community @boyd_IT
Unlicensed version is not a problem buddy
Robot does not exist is the key point
Kindly check whether the machine is connected to the Orchestrator
The machine name in orchestrator and in your system should be same
For more info on this

Cheers @boyd_IT

Thanks for your help!

The machine is connected to the Orchestrator, and the Robot is created and connected to the Machine and the Environment in Orchestrator.

I noticed that the machine name in the bot orchestrator config is in all caps, but the hostname is not. The machine name inside Orchestrator matches the hostname.

The install location seems odd, as well. I’ve reinstalled it as administrator, but it always installs to %localappdata%\UiPath rather than Program Files.

Has the installer changed a lot for 2019.6.0 ?

Is there anywhere I can see the logs for the connection/license attempt by the Bot? The Show Logs option brings me to a folder where the only log available just shows Studio activity, but no Robot activity.

Hi @boyd_IT

Welcome to our UiPath Forum! :slight_smile:

I agree that something is most likely misconfigured in Orchestrator. Could you give a screenshot of:

  • Orchestrator Robots tab
  • Orchestrator Machines tab
  • your Robot setting page

We’ll go from there :slight_smile:

Hi @loginerror

I have same issue with orchestrator here my setting

Orchestrator Robots tab

Orchestrator Machines tab

Robot setting
image

Can you help me?

Hi @dianwinata88

Welcome to our UiPath Forum! :slight_smile:

A couple of things:

  • please use the full address of Orchestrator in your Robot window:
    That entire bit:
    image

    Into here:
    image

  • please make sure that your Orchestrator instance has the licenses assigned from your Cloud Account

And maybe a third thing - the latest version of Robot is this one:

You can get it from here: https://platform.uipath.com/portal_/resourceCenter
And give it a fresh install as per this guide here:
How to fix your Studio installation / Licensing issues

Please also carefully follow the guide on how to connect your Robot to Orchestrator here:

Hi @loginerror - found this post because I am experiencing the same issue. Everything seems to be set up correctly according to the steps in the documentation, but I am getting the “Unlicensed - the robot does not exist” message in the robot tray. I believe Orchestrator has the licenses from my Cloud account but please take a look below and let me know if something is missing. I’ve also included other screenshots to verify what I’ve done so far.

From the Cloud account…

From Orchestrator…

Robot settings…
image

Does the Orchestrator license need to be updated somehow, to indicate a number of attended/unattended robots (and then I would change “Type” to “Unattended”)? If so, how to I go about updating the license?

Hello @boyd_IT @dianwinata88 @Palaniyappan curious if either of you could help- see my previous reply. After looking into, sounds like I should be fine with the 2 studio robots as part of my Community Orchestrator license. I even tried changing the Orchestrator URL to platform.uipath.com… (vs. demo.uipath.com… like I had originally). Many thanks!

Hi @bsylvester

One thing for sure, please use the platform address instead of demo one.

Could you try assigning all the licenses (including the attended ones) to your tenant?

Also, could you check your Studio installation folder if there are some new versions installed?
%userprofile%\AppData\Local\UiPath

If you are on a Preview channel and something went wrong with the auto-update, this could be a sign of Robot service not working properly.

Thanks @loginerror. Turns out that I was missing a domain with my user name. For everyone reading, best way to get this is “whoami” in command prompt. Once I updated this, everything showed up as online and licensed.

3 Likes

Thank you @bsylvester. I was having the same issue and the “whoami” command helped me find the correct user name.

2 Likes