Robot not showing in Orchestrator when trying to run a Job

Hi,

I am trying to run a job is on Orchestrator but my Rot is not showing up under ROBOT, I tried to refresh but nothing is apperars


image

2 Likes

@tshedzamclay

Could you please help me with screenshots of Robots, Machines page once. Will check and update you.

Fine buddy @tshedzamclay
we need to make sure certain criterias are made available
–First one, make sure a machine is created first which has a machine name similar to that of the machine name in the robot tray of your system where studio and robot is installed, i.e., the machine name in your machine must match with the name of the machine created in orchestrator and their key must be same as well
–Next, create a Standard robot (press the + symbol while creating robot in the robot tab where we got two options like standard and floating robot, click standard robot if we know the machine where we are going to run the robot) in the robot tab in orchestrator with the above created machine mentioning that in machine option while creating Standard robot
–once after creating the robot make sure that the robot is tagged to a environment and for this click on environment tab in robot tab of orchestrator and create a environment and add the above created robot to it…This is very important as only if this is done, the robots will get displayed when a process is run as you were trying to do
–Then make sure that the robot is connected to the machine, and this can be done in robot tray in your machine once after simulating the above steps like creating machine, creating robot, creating environment…by start -> Robot -> Settings -> Paste the Machine key obtained from the machine in machine tab in orchestrator and -> click connect. Now the robot will get connected (still this doesn’t impact your step, but is more important when we run the process from orchestrator)
–Then create a process in process tab with the environment which has the robot with which you want to execute (above created environment) and that is very important as only when we mention the right environment which is tagged with robot, then only we will be getting displayed with the robot list for the steps you were trying
–once after creating the process now go to jobs and click on play button and mention the process name and automatically the robots will get displayed based on the environment tagged to the process while creating process, as that environment only has the robot tagged to it…

Thats all buddy you are almost done
Kindly try this and let know for any queries or clarification
Cheers @tshedzamclay

1 Like

Hi my robot is provisioned to my machine, I didn’t have a problem with this in version 2018 until I update to 2019


2 Likes

fantastic
you have no issue with machine connection to orchestrator
but still see here buddy
there is no Environment tagged to this robot, so thats why when we are trying to run a process we didn’t get any robots under the specified environment while creating the process


–so kindly create a environment by clicking here

–click on the right end of the environment with three dots, the environment that we mentioned while creating the process…click on it and add this robot “ROBOT” to it and click update
–now when you come back to this robot tab we would be able to see a environment tagged under the column ENVIRONMENTS

–After that we would be able to see the robots getting listed when we try to run the job

You were almost done buddy
Kindly try this and let know
Cheers @tshedzamclay

1 Like

Thanks for the help.

Cheers

No worries
Cheers
@tshedzamclay

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.