Robot not visible while creating Job

Hi Team,
I am trying to create a job but not able to see the robots assigned under the selected environment.
I have Assigned the robots to specified Environment as well.
Please see the attach screenshots as well

Also i have assigned the robots to specified Environment

Also the robot is provisioned and connected with orchestrator.

Kindly Help.

@benajir I guess it is because the Robot is of Type Studio, You need to Create an Unattended Robot if you want to run it From the Orchestrator.

1 Like

This link may help you, @benajir

1 Like

Thanks @supermanPunch .It worked :slight_smile:

1 Like

Thanks @Manish540 .Was following the steps as mentioned ,but was using Robot type as Studio and thats why it wasnt comming.


i have same issue .i have changed to unattended robot but i am not able to publish it is showing error

machine key linked to another machine?can you able to say me solution?

may i know what type of machine i have to give for unattended robot

Go for Standard Machine while creating a new Machine.
First one, make sure the machine you’re creating should have a machine name similar to that of the machine name in the workstation the robot is installed. You can check Machine name in Orchestrator settings from UiPath Agent or using Command prompt.
Second one, make sure the published process and robot are in the same environment and finally ensure the robot is connected as well.
Still facing error? Then post the what type of error you’re facing while publishing process from the studio.