Robot gets disconnected everyday from VM

Hi guys,
Need some help.
I have installed Uipath Robot on an enterprise virtual machine running Windows Server 2016. Every day in the morning I get a tenant error (#1222) from the orchestrator that my robot got disconnected from the machine.
This is weird since the machine never restarts being virtual but the robot connects back as soon as I log in to the virtual machine through Remote Desktop.

I have set the UiPath Robot to start during system startup and as soon as I log in, I see it getting started again. I have talked to my IT dept and they said that the remote desktop shows no record of previous re-starts and it must be the application which has some issues.

Can someone help me out regarding this? If I have to log in to the virtual machine every day to keep the bot connected, this kind of defeats the purpose of having an unattended bot which should work without any human intervention.


1 Like

Hi @abchakraborty,
Do you have any related logs from Event Viewer? Please also monitor TermService (Remote Desktop Service) and it’s behavior.
Please also tell me what robot is doing on the machine? If it’s monitoring something and have longer moment of doing nothing maybe you should check if there is no GPO set for logoff after defined time of no input from logged session.

Hi Pablito,
Sorry I do not have any event logs but this is what happens:

This thing turns grey every 24 hours and turns back green as soon as I log in to my virtual machine.
My virtual machine shows no signs of re-start and I have no idea why it disconnects in that case.

To answer your second question, I am using an unttended bot that runs every 4 hours to scrap some data from a webpage and load it into a SQL Server database. Every Tuesday, it also has some scheduled tasks where it connects to the database, generates some insights using a SQL query I wrote and sends them through Slack API to different people in my organisation. There is no continuous monitoring job as such.

Seems that it behaves like Attended robot. Please check what’s happening with UiPath services on machine where you are not logged in. Seems like they are all stopped instead of running.

Can you please guide me how to check UIPath Services?

If your machine is a part of domain you should be able to check all services from services console by right clicking the root tree and use Connect to another computer button.
The you need to provide IP or Name of the machine.

The other way is to monitor services from powershell with use of these commands:

Enter-PSSession (IP or ComputerName)

And then

Get-Service | ? {$_.DisplayName -like “*UiPath*” -or $_.DisplayName -like “*Robot*”}

Regarding services please check here:

I tried using powershell command and I got no services result for Uipath or Robot.
Here is the screenshot:

If no services are available on remote machine then this will be the reason why it’s getting disconnected. Maybe try to disconnect robot from orchestrator and pair it again an set unattended robot again to check if problem will be still.
Are you on Enterprise license or Community? If enterprise then you can also contact with our Technical Support.

Thanks Pablito. I came across an answer which said that Uipath Robot has to be started as a service and not as an application.
I tried to check the services in the VM but there is no UiRobotSvc in the services to start. So, I tried to run it manually by clicking in UiRobot.exe
However, I still cannot see the service running. Anything that I might be doing wrong?

Please check out this instruction:

I think your robot was installed incorrectly.

Thanks Pablito! I have installed the robot correctly and see UiRobotSvc running. But, whenever I am running a job now, the Remote Desktop Session gets automatically disconnected. Also the processes which were running earlier are now throwing error. The steps like open browser are failing

Any idea what might be the cause?

Please check if robot has enough time to enter the RDP session. You can extend it like it is described here:

I have a similar issue, I have a RDS that when I “connect” to it from my physical laptop and keep the window minimized my unattended robots work just fine, but the minute I disconnect the RDS screen from my laptop windows seems to auto disconnect from the network, preventing uipath “UiRobotSvc” from working. (kind of makes sense, orchestrator cant connect if theres no internet).

However, I have checked power settings, group policies etc and I am stumped.

  1. Power settings are all set to never hibernate or sleep
  2. Machine group policy settings are set to allow network connectivity when sleeping (just in case)

Check if the prerequisites for installing the Service Mode robot were set as it is presented here Installing the Robot

Make sure that your robot user account doesn’t fit under Deny log-in policies for User Rights Assignment, your robot in Orchestrator has the LoginToConsole Enable and set to No and before running the job from Orchestrator, the robot is not disconnected but Logged out (from cmd.exe if you will run logoff it will logout your robot user from the machine).