Robot does not exist / Connected, Unlicensed

Hello

I am running across the same error. When i try and run a file from studio, it says does not exist. I opened up my UiPath Assistant Orchestrator settings and it says connected, unlicensed. However, when i check online under licenses it says, I am licensed until 2021. My robots were working before the update and I have the community version. Below is a screenshot showing the error message and the connected, unlicensed. Please help and advise on how to resolve.

Thanks,

Please hover over the Status message in UiPath Assistant / Agent Desktop, this will reveal a more specific message.

Example:
image
“Connected, Unlicensed”
Robot does not exists

This can occur for a couple reasons. Please make sure that you have

  1. Created a Machine record with a name matching that of your Robot’s host
  2. Have provided the generated Machine Key in your Orchestrator Settings for UiPath Assistant / Agent Desktop.
  3. Created a Robot record referencing the correct Machine, Type, and valid Username / Password. *Note: username MUST be in the format of domain\username if you are part of a Domain or hostname\username if you are not.

So long as the three are correct, even if the password is wrong, it should show “Connected, Licensed”.
image

Please review the following for other Status messages and their meanings.

1 Like

Hello,
this was the same message I received while orchestrator was connected but not licensed and I started a workflow from Studio.

In my case, I had to change “Domain\Username” and “Password” in the Robot-definition. I used “UiPath\myUsername” and “myUiPathPassword” as I have seen it in the introduction video.

The correct one was the credentials of my PC, on which I installed Studio. “MyComputername\MyUserNameFromMyComputer” and “MyPasswordOnMyComputer” made everything work.

I hope this will solve your issue too.

Best regards

Andreas

Hello @Richd22

It is because bot machine connected to orchestrator but not licensed.

As there was a new requirement for connecting to orchestrator, Below i gave the link, check and follow the steps, hope this helps

Thanks

1 Like

A post was split to a new topic: Connected Unlicensed, Robot does not exist

I inserted my domain\user in robot (retrieved with cmd “whoami”), now it works.

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.