Robot does not connect to Orchestrator

I am not able to connect Robot running on local machine to Orchestrator running on the same machine. There must be some basic issue which I am not able to locate, tried searching on different discussion topics.

UiPath is free edition, Orchestrator is Community edition and I am trying to connect as Developer Robot.

Any help here is highly appreciated.


Hi @kavitaj9

Please hover your mouse over the “Robot unavailable” text message for a clue on what is going on:

Moreover, the Orchestrator CE is hosted by UiPath, not locally on your machine :slight_smile:

it says - “Robot does not exist”

Please make sure that the domain\username is exactly as the output of a CMD command
whoami on your Desktop.

See step 5 over here:


Try the below steps and see if it resolves the issue:

1 Like

thanks… it worked.

1 Like

Hi all, i’m facing the same issue and tried the command line. My domain name is asus.

Not sure why the error message says “Robot does not exist”


what is your username?
do a whoami in cmd and use that as the username for your robot and pass the windows login password also



Thanks for the reminder. Was using the correct domain name but wrong username. :slight_smile:


Thank you…It worked


I did like what you said. But still robot is unavailable.
Machine: Machine Template, Robot: Development Floating Robot.
Can anyone help me to fix this issue?

Can you hover on the status and let me know what the message you get?

Robot does not exist.

You have not created any robot?
Create one under robots tab and use this machine.

1 Like

I done everything. But i don’t know why its not working. Standard machine is working but floating machine is not working, that’s why i can’t understand. If i try to do in attended means showing error to update the license.

1 Like

I have done the steps for floating as well and it works perfectly fine.

I think your username is incorrect. have you tried whoami in your system commandprompt?
And you password should be the same as the one you use to login to your system. verify once and confirm.
You do not need to select attended.

I tried that, the username is copied from the whoami command and password which is my system login password i have given.