Robot Connects and then Disconnects

after the installation of uipath community studio I login using the assistant to sign in to my community cloud to get my bot licensed everytime for the past week my bot assitant has been asking me to sign in again in order to get licensed. Every time when i sign in i get connected and licensed for a while but as soon as i open my studio i get “Your login has expired. Please sign-out and sign -in again.”
This has been happening for a while and i tried changing my licesnse from attended developer pro to unattended and in the process i also realized that im not getting the option to change my attended license type
image

Hi @olmccb

Would you mind using the option to Copy to Clipboard and then attaching the output here?

Also, let’s take the issue one by one.

For this error message:
image
Could you please Sign-In, then Sign-Out and then Sign-In again? (all from Studio or Assistant)

As to the licenses, could you share your user settings in Orchestrator?

Hi there @loginerror i did as you said to sign in and sign out and sign in, still same situation. here’s my user settings i wanted to insert the other optional settings butit wouldn’t allow me, but for the Unattended Robot settings, for my domain\username it is simply my laptop, for Credential Store i have Orchestrator Database, for Robot Settings none of the options are enabled. Thank you for your help!

1 Like

Could you try closing Studio/Assistant, deleting this folder and then trying again?

%appdata%\uipath\oidc

Also, I would suggest selecting the “Automatically create an attended robot for this user” option.

hey there @loginerror i deleted the folder, btw it was empty and enabled “Automatically create an attended robot for this user” but its still the same
image

Could you maybe monitor this folder while you are signing in to see if the file is getting created there at one point?

For context, it is the location where the session file is stored, which means that if Studio is unable to save it, it would time out the session the moment it needs to refresh it by using some values from the file that should be created in this folder.

Is the machine maybe under some policies that could prevent the creation of the files in this location?

Hi @loginerror i monitored the folder and it didnt get created when i opened studio or logged into orchestrator. Im running studio on my machine and i havent changed any policies out of the blue it just started happening.

Understood. This could be a potential bug, but one thing to still try would be a completely clean installation of Studio, if something got corrupted:
How to fix your Studio installation / Licensing issues

Could you also run the image that you can find in your Windows Start menu and send me the output zip file via the private message @loginerror? It would help.

@loginerror do you mean 1) completely uninstal and install the latest verstion and 2) do you want me to run the diagnostic tool now or when ive got everything set up
Thank you!

Yes, full reinstall. As for the tool, it’s better to run it beforehand as it will collect the logs of studio that would have otherwise been deleted by the clean install process.

ok gotcha thank you!!

Hi @loginerror i ran the diagnostic tool, how do i private message you to send them