Robot connected to orchestrator. But status is unlicensed. How can we resolve this

Hello,

I’m trying to install UiPath enterprise edition - trial version.

Now I have connected my created robot to Orchestrator. But it’s status is displaying as ‘Unlicensed’

As I read in previous articles it says to create the machine in orchestrator with the same machine name . So I have verified it also.But still I’m getting this .

image \

How can we resolve this?

Thanks !!!

Hi,

First, can you check Domain\Username of the Robot settings in the Orchestrator is same as output of “whoami” command from command prompt on your PC?

Regards,

3 Likes

Hi @Yoichi,

Yeah, Checked. Both are same.

One thing to clarify : Do we need to activate ocrhestrator separately adding the license code given by UiPath? As described in Activating Your License

Hi,

Yeah, Checked. Both are same.

Backslash and slash are often mistaken for each other. Is it also same?

One thing to clarify : Do we need to activate ocrhestrator separately adding the license code given by UiPath? As described in https://docs.uipath.com/orchestrator/docs/activating-your-license

Basically we don’t need this process if we use cloud orchestrator.

BTW, If you launch UiPath assistant, which error message is displayed? (Connected, Unlicensed?)

Regards,

1 Like

@Yoichi

Yeah, All the things are same with the names.

I’m using cloud orchestrator as it’s url is https://cloud.uipath.com///

Hi,

Other possibility, do you have enough licenses on orchestrator? For example, if you have 1 testing license and create 2 robots as testing on orchstrator, 1 robot will be unlicensed.

Regards,

1 Like

Hi,

I have only one Robot and its status is displayed as available in orchestrator.

This is how my license page displayed

Hi,

We can see consumption of license from the following menu of orchestrator. Can you also check it?

Regards,

Hi,

It is looks like this.

Hi,

There seems licenses for Studio and StudioX. But not for Attended or Unattended.
Which license type is set for your robot? You can check it as the following image.

Regards,

Hi,

It is like this

Hi,
When I navigate to edit the robot type to attended or Unattended it displayed this error message,

image

Hmmm…

Your robot settings seems right.
For now, unfortunately I have no idea about other possibilities of this matter …

I think you can contact support team of UiPath because your license is Enterprise trial.

Hi @Yoichi

I have googled above issue and I read some article and it is below.

After doing it as above I got robot type as I required. And then I checked the Robot tray. Its status has been changed to ‘Connected, Licensed’

Thanks!!!

3 Likes

Hi,

Great to hear that!
Thank you for sharing your solution!

Regards,

1 Like