Right click does not find element


I right click on an element to do “Save Link As” but even Uipath recognizing and validating the element has failed a lot and automation stops many times, can anyone give a tip to improve this?

It’s a small element on the screen, and it barely changes position.

Could you open it in UI Explorer and give us a screen shot?

Hi @ptrobot
That way?

How does it look if you go one step up?

Hello @Rodrigo_Buch ,

I hope you have provided the css selector in the selecto for the click activity. Instead of that in UiExplorer are you able to see some attributes with name “SaveAs” or some other names which can be constant.

Here as you mentioned the Save button position is changing , so the css will fail. Also if you are using the modern design, plz try to use the Appl/Web recorder to record only the click activity. It will give you a selector tagged to an anchor.

Hi @Rahul_Unnikrishnan

That way ? Can you give me an example please?


Like this.

Use App/Web Recorder.

@Rodrigo_Buch Can you disbale CSS-Selector and tag attributes and try enabling parent class and class, see how it goes

Click the orange Firefox button, then Options. Under the download section on the General tab, select “Always ask where to save files”


I used this activie is the same as you gave as an example?
But it’s not working

Here download button is selected as anchor instead of the target. You need to choose download button as the target and use some other as anchor

You’re right, the target and the anchor were switched.
I made the change but it still doesn’t work, go straight to the next action and it’s just the error.

Plz run it in detail bug mode and sweet highlight element and use step into method to check the flow… Check whether the element is getting highlighted for the download button.

Hi @Rahul_Unnikrishnan
I executed Debug with Slow Step and on the right click activies there is no mistakes but does not perform anything.


Are you trying to download the file? and whats the purpose of right clicking?

Also can you enable the Highlight element feature in the debug mode and then execute in slow.
Then you can understand where the click is happening.

Yes I’m trying to dowload I need to click with the right button because the files have different extensions .jpg .jpg and .png .pdf

I did it with highlight enabled but as usual nothing or errors happened

instead of right can you check with Left button and see some action is happening.

With the left button it worked, with the right button the element even appears being clicked when I use the highlight but it doesn’t open the menu to save as and then the next time the robo stops working

if it manually works with Right click, it should work with automation also. Can you try to record that portion alone using App\Web recorder and select Right click as the action in the click activity.
check how it is recording. Also if you are using community version can you switch to studio and try your scenario instead of studiox

I tried using this option and the behavior is the same he makes the right click but the menu to save as does not appear


I am using this activities is this correct?