Dialog "Save as" no selector with Edge?

When trying to download files from Edge I can not reach the “Save as” button, I always just get the underlying elements on the web page when indicating. Change of the UI Framework has no effect. Any solutions for this?

1 Like

@moenk

have you installed Uipath Extension for the edge?

Thanks

1 Like

Well of course how else I’d get the underlying elements on the web page?

No worries
If we are using CLICK activity then make sure that SIMULATE CLICK is enabled
—and also the waitforready property as Complete in the property panel of click activity

Cheers @moenk

You know the difference between Internet Explorer and Edge? These are two different apps.

This does not work with Edge, did you tried that yourself?

Fine
Did you enable simulate click and tried once with click activity
Cheers @moenk

I dont want to click, I want to check if the element exists. But this was not the question: I need a valid selector for the “Save” button in Edge, as it can not be indicated.

Hmm
Fine
I would like to know what will be the next step once after we come to know that element exists
@moenk

I know this of course and it has nothing to do with Edge. Please note we are not talking about IE. Spying element on Edge is fine, but not the system dialogs.

@moenk
We are also facing same problem, since the Edge extension is experimental, we might face this issue.
Wait for the official release and currently use IE.

Try using Click Text activity.

Use delay activity to wait till pop up appears and after that use click image activity. Or click activity with simulate that will work.

Yes, this would be my next approach if UIPath fails to get a valid selector, third would be surface automation aka click image. The click text later would not work any more when I need to close the download dialog.

Great information, do you have planned timeline for that? Company GPO enforces the use of Edge, the project used to work fine with IE, but that is not an option any more.

No idea about the timeline. But below are links which speak about the known issues in Edge extension.


Hi Moenk, I ran into the same issue and I found a fix. When you use the ‘Indicate on screen’ to create a selector automatically, press F4 before click on the Save button. This will switch the UI Framework from Default to AA. Do not ask me what AA is but all I know is after changing this, you are able to select all the buttons you were not able to before. I understand my reply comes very late but maybe this will help someone else. Cheers.

2 Likes

Hello,
this answer is the correct solution.
Adding: AA stands for Active Accessibility and is one of the 3 UI Frameworks you can choose from in order to indicate elements. You can also find this setting in the UI Explorer Top Bar Button named ‘UI Frameworks’.
Regards