Remote Desktop Studio is missing selectors

Hi,
my test environment enables logging as robot user. Me and my colleague encounter issue with UI selectors in Chrome being off by few centimeters of actual element. This goes for AA, UIA and Default engines. We are using Studio 2019.10.1 Enterprise Edition.
Scenario:

  1. Person A is logging in, working on machine, selectors are ok. Job saved, signing off the machine effectively ending the session.
  2. Person B is logging, tries to work but selectors for click activity are shoving wrong space - like liitle above and to the right of the button.
    Same goes for debugging mode - selectors are off and missing their targets.
    B is signing off.
  3. Person A logs again and checks. Everything is working fine for them.
  4. B logs, issue persist.
  5. A logs taing over B’s active session. Now A is experiencing issues.

We tried to disable/enable Chrome plugin but there is no clear way what helps. We are still troubleshooting and looking for clues.

We were thinking about resolution change - both of us have different sys. resolution while connecting to remote desktop. But UI engine is independent of object resolution.

Hello @Rafal.Wrycza ,

Does the end application support Simulate click/Type option ? Is so, please try enabling such options and check if the process is working.

Cheers

Note that you don’t have to set the click type in each activity. You can set the default for the project in project settings.

1 Like

I’ve learnt it hard way, there are some fields that depends on resolution. We worked with a SAP online tool and that had different selector elements for a same button, it was failing on the VM and working on VDI.

Do check if the resolution is the issue. Make bot to establish the connection with same resolution. You can do that using settings of the application you use to connect, if you are using terminal you can simply select the connection parameters by right clicking on the machine name

1 Like