Click activity works different in different resolutions?

Hi all,

I’m using a Click activity to click on a hyperlink. This hyperlink is inside a table element, which is also clickable. UiPath is installed on a VM and all execution is done on that one machine only.
The selector is on the < a > element using the id of this html-element.

When I log in to this Remote VM from Local Machine 1 having the resolution 1366x768 and executes the process on this VM, the robot will click on the table element and not on the hyperlink.

However, when I log in to this Remote VM from Local Machine 2 having the resolution 1920x1080 or 1280x768 (or some other resolutions) it works fine.

What is the reason of this as everything is executed on the same Remote VM. How can that be solved?

Hi @P_S,
One of the reason why it happens is that your selectors might be not dynamic and refers to general object. Please make sure that they are referring to exact element you need. Another way to solve it (in case where it’s still not working) is using automation through Orchestrator where you can define exact resolution for you robot attached to the machine.