Remote Desktop Resolution issue

Hi!

We experience a problem with Image activities in UiPath (e.g.: Click Image) when working through Remote Desktop (RDP).
When trying to indicate image on screen, the window size changes (see screenshot). We believe it might be due to resolution but we are not sure.
Therefore, this particular activity is not working properly and cannot correctly find and click images.
We were not able to find the UiPath.settings file on the Remote Desktop UiPath ProgramData folder.
We copied the file from computer and set the custom resolution in the UiPath.settings file but it did not fix the problem.
We also set the resolution of the Remote Desktop session to be the same as the resolution of the computer we are using.

Has anyone experienced similar issue?

Thank you for your help.

Tomas

1 Like

Hi @Tomas,

Try this way
use launch workflow interactive activity
here you can specify the height,width and Depth of the screen

Refer below URL

Regards,
Arivu

2 Likes

@Tomas
Refer this it might help you

Regards,
Mahesh

1 Like

Thank you. Yes, it was the first thing we tried. As I said, the UiPath.setting file was missing, so we copied the file from “another” computer and changed the resolution parameters. Problem was not solved.

1 Like

Hi @Tomas

I have a similiar issue, where i have unattended robot and no Orchestrator, and no Uipath.settings file.
I have copied the file from another machine, but there is a row called “SecureLicenseKey”. What did you enter here?

Edit: found the solution here

https://robot.uipath.com/docs/uipathsettings-file-description

1 Like

Hi

I am also facing the same issue, when I try to do in remote desktop from uipath it was not recognizing the image due to the resolution change. I tried to fix but UiPath.Setting file is missing.
Has anyone have the solution please help me.

Thank you,
Bhavana

1 Like

I as well am seeing this issue. I am finding that selectors are misaligned with the actual text. I have to click on a selector in some cases that is 3 rows above the actual text row.

1 Like

I am also facing this issue, whenever I use indicate screen from Click Image activity, screen auto zoom in , any help?
@Karthick_Settu @maria.josephina @PrankurJoshi

1 Like

I found that changing the screen resolution has helped… reducing it. We had created the process on a low res PC, then moved to a high res PC and it would fail. When we ran it on a low res PC, the images aligned.

1 Like

It would be nice to see real solutions for these resolution issues… most of answers are so basic but real info is missing.
For example: Why UiPath.settings resolution settings does not work? How to diagnose why? Where are error / log if this works or not?
For now this is just blackbox where people try 10 different tricks that does not work.
Example, reducing dev resolution… no, if resolution is possible with remote desktop machine should handle it even when running its own. This is commercial product, support should be good.

Some info for devs that are wrestling with this… if you are running vmware (with windows server) there must be enough gfx memory to support higher resolution. And when this ok you can use windows remote desktop client and get that resolution for that. After that it should be ok to run robot from scheduler with that same resolution. Windows somehow stores “last” users login resolution and should use it is scheduler process is started with same user account. But not always as in my case. 2018.4.2 robot only gets low 1024768 resolution when running using scheduler (It is same desktop as I used before logging of to check how scheduler run goes, but resizes 19201080 -> 1024*768 no matter what uiath.setting have.)

3 Likes

This is frustrating, do we have any hints or still nothing,

Hey buddy, @loginerror , maybe you know?

I have the same issue, setting everywhere (in Orchestrator, in UiPath.settings file) desired 1920/1080. When running from Remote Desktop it is working nice in this resolution, but from Orch it always goes to 1920/855 from some reason…

1 Like

Hi @Roman_hruska

I would suggest you to contact our technical support for more direct assistance. A screen sharing session might be more fruitful rather than trying to try a bunch of different things from the forum.

1 Like

@Roman_hruska

Did you ever get an answer on this?

1 Like

Hi, not really, but our infrastructure team (VDI team) was able to change the resolution, so in the end for me the problem was solved, but I have no clue how exactly. But probably from the VDIs administration app.
Good luck!

That is funny JJDev – support is non-existent.

1 Like

Hi @Tomas
This problem was occurring for us once. Not sure what was causing this issue but restarting the Remote Desktop fixed this every time.

It could be the problem with the remote desktop tool you are using. Try changing the tool and use tools like logmein, R-HUB remote support servers, teamviewer etc. and check if the issue is resolved.

@JJDev - I absolutely agree. If you search through the forum you can see that UiPath has been well aware of this issue for at least a year (possibly even longer), yet they continue to do nothing at all about it. Fiddling with settings files and hacking a workflow with ‘Launch Interactive’ is NOT a viable solution - it is avoiding responsibility for a problem in a product that they should have fixed long ago.

Hi @PhilDev

Could you maybe create a new topic with your specific issue? :slight_smile:

I believe it should be much more robust on the latest versions.

A post was split to a new topic: I have unattended robots with orchestrator and have 4 robots. When I login to server manually and run workflow it works properly but when robot runs automatically(unattended) it shown application screen bigger than usual and it’s not running