Read range : Your stream was neither an OLE2 stream, nor an OOXML stream

excel
activities

#1

Scenario:

Read Range Excel File (.xls extension)

Steps to reproduce:

Try to read an excel file with Read Range activity.

Current Behavior:

Throws an exception:
Read range : Your stream was neither an OLE2 stream, nor an OOXML stream.

Expected Behavior:

Returns the spreadsheet as a Datatable

Studio/Robot/Orchestrator Version:

UiPath Studio version: 2016.2.6274
OS Version: Windows 7 (64 bits)
Others if Relevant: (workflow, logs, .net version, service pack, etc):

Excel file:
VL06O - BR.xls (43.7 KB)


#2

Works fine for me with both Excel Activities. Any package updates recently?

You need to downgrade your excel package


#3

Hi @vvaidya,

Yes, this is really odd, I’ll try to reinstall this package.


#4

I reinstalled this package and the error continues.


#5

Can you double check your excel version which is installed should be 1.2.6256. Restart your studio if possible.


#6

I don’t think downgrading this package is a good solution, let’s escalate this to the UiPath team, so they can properly analyze it.

@qateam


#7

#8

you`ll need the workbook activity in order to work with xls files.


#9

Hi @Gabriel_Tatu,

I’m not using Excel Scope activity in this case. I’m just using the Read Range activity as you may see in the screenshot.


#10

its a specific issue this, with your excel file. we will investigate further.
as a workaround, save it as xlsx and try again.


#11

Hi @Gabriel_Tatu,

Did you manage to test it? I mean using the same UiPath version and the same Excel Activities package?

I don’t think I’m going do this workaround because it was working before this update and I have several .xls files in my current project, so saving them as .xlsx would cost me too much time.


#12

xls support was not available until this update, which package have you used so far and worked?


#13

Really? Because it stopped to work properly this week.

I believe that the previous version from Excel activities package was working, I didn’t try to install the previous one, but what I’m sure is that this current one is not working and also we have another topic talking about some problems with the latest Excel activities package here:


#14

Please read this topic:


#15

I solved mine by installing previous excel activities. :slight_smile:


#16

then, also as workaround you can try using excel scope activities,if you still have office installed. it should work.


#17

if you provide the test file and maybe the workflow too, i can investigate more.


#18

Yes, kindly check it.

I’m using the same excel file that I have uploaded below and I’m using the latest Excel activities package.

Main.xaml (4.8 KB)
project.json (236 Bytes)

It works if use it inside Excel application scope. But, my main concern here is that it was working before without using Excel application scope, but now it’s needed.


#19

this issue should be fixed in a future update, check Package Manager for updates frequently.


#20

Hi @acaciomelo

I’ve met the same problem and we found the .xls file we use is actually a csv format file name end with .xls so trials of using read range and read csv activities are all failed. Our Uipath ver is limited at 2016.2.6344 due to development environment, is there any solution for this in this version?