Read range activity error1

I have downloaded one excel file in form of xls
but In read that file i am getting error like Read Range: Your stream was neither an OLE2 stream, nor an OOXML stream… Now what i can do?

Hi @Kuldeep_Pandey ,

Have you tried to use the Excel Read Range or the WorkBook Read Range activity ?

Do try with the Excel Read Range Activity as well if not tried and let us know what is the outcome.

I tried Workbook

Hi @Kuldeep_Pandey,

To resolve this issue, you can try the following steps:

  1. Check if the file extension is actually .xls. Older versions of Excel use the .xls extension, but newer versions use .xlsx. If the file is in .xlsx format, you can use the Excel Application Scope activity to read the data.
  2. Open the file in Excel and save it in a supported format, such as .xlsx or .csv. Then, try reading the file using the Excel Application Scope activity or the Read CSV activity.
  3. If the file is in a binary format, you may need to convert it to a supported format using a third-party tool or an online converter. Then, try reading the converted file using UiPath.

I hope this helps!