Problem with following the guide to create a UiPath Studio basic process

I followed the video and steps mentioned in the following site to create a basic process in UIPath Studio.

Creating a Basic Process (

I noticed that step 9 (i.e. From the Activities panel, drag a Write Line activity. In the input text field, add the previously created variable. This activity writes the scraped data to the Output panel) is not shown in the video.

Based on the example which I downloaded from this site, there is a WriteLine activity between the GetVisibleText and OpenApplication activity. However, there is no WriteLine activity mentioned in the video. Shouldn’t the steps and all created objects be the same in the video and the example be similar?

When I ran the process after creating, the IE browser and Notepad were launched but there is no scrapped text appearing in Notepad. I have checked the steps again several times and also tried adding the WriteLine activity between the GetVisibleText and OpenApplication activity but problem still persist.

Any idea on what may be incorrect?


The “Write Line” activity is used for Debugging purpose , which writes or prints the data in the Out Put panel of the Studio.

Please check the below link for reference

Write Line (

Please use a “Type Into” activity after GetVisibleText activity and pass the OutPut Variable of GetVisibleText to the Input of Type Into Activity.

Please find the Attached Scree Shot for Reference.



Open the browser manually and try to highlight the value and check it is validated correctly and also check that

I think so the Type Into has a selector error check on your side run again

After changing it has ran for me


Also please find the attached xaml file for reference.
Main.xaml (10.5 KB)

I have added a WriteLine activity after the GetVisibleText activity for debugging. During running of the process, the scrapped text did not appear in the output panel. I have already specified GetText as an output for the GetVisibleText activity. Not sure where the problem lies.


can you please check if the Ui Path extensions are installed properly for the browser you are using.Please try to re-install the extensions.

If everything looks fine , please use the xaml file sent over the thread.

The UiPath extensions look fine.

Here is my process.

Can you please help to share me the xaml file. Will check and revert back.

How do I share the xaml file here?

Please Upload the xaml file in the thread.


I got an error message as follow.

Sorry, new users can not upload attachments.
Read more here on how to easily remove this restriction.

Please check the Selectors, and try highlight the value .Please change accordingly and try to run again.

It is working after I changed the Selector value to be the same as the example.

In this case, does it mean UiPath Studio will extract all the text under the H1 html tag?

Thank you for your assistance.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.