Problem trying to select a value from a dropdown

Hello I’m new to UIpath and have been trying to figure this out for hours. My company uses IBM TM1 web for budgeting and I’m trying to automate running reports in there. I first tried to use Select Item but I got the message that the control doesn’t support select item. Then I tried to use the recorder but the recorded steps failed as well (UI element can’t be found)

this is part of the codes from the UI explorer where the line errs out:
<webctrl aria-role='treeitem' id='dijit__TreeNode_651_label' tag='SPAN' />, attached is a screen shot of the drop down, the text strings I need to select may locate at any level, they can be selected after clicking on those little down arrows to the left of the texts (multiple hierarchies exist). Can someone please let me know how to go about this task? thanks so much in advance.dropdown

Hi @lynnsong986 ,

Use Click activity. After click use hot key to go down. Now use type into activity and search the value. Next use click activity to select the value

@manjula_rajendran thank you so much for helping out. I tried, here is what I found:
Once I clicked on the black down arrow inside of the Companies box, the dropdown showed up (the code works here), I don’t need to use hotkey because the cursor automatically is placed inside the “Find subset” textbox, I tried to use “Type Into” here together with “Enter” but I got the error message that UI element can’t be found. this line here can’t be validated on the screen.
<webctrl id='dijit_form_TextBox_3' tag='INPUT' type='text' />
but it works manually if I type that text string.

then the next dropdown beside the Business Units - Forecast Variance box is even more problematic - the search box doesn’t work, I need to use the down arrow to locate an item, click on the blowup arrow to the left of an item to see the children, sometimes grandchildren. I always got can’t find UI element no matter what I do here, I tried anchor base, but didn’t work either.
Please help.

@lynnsong986 ,

Try to get the selector the UiExplorer.

Did your issue solved?

Try this
ValueFromDropDown.xaml (10.0 KB)

I think you should change the workflow little bit as per your need.

Thanks for helping me out. The problem with these dropdowns is that they are not real ones (I check the UI explorer and those boxes have only one child “Span”), and hotkeys don’t work with them, I can’t use keys to move up/down at all. I’m reading some other ways posted by others, hopefully I can figure it out.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.