Select Item working for Drop down but no further actions on application

activitieserror

I have a dropdown/combo box in an application. On clicking the dropdown list, it shows the item in it. Once I select specific option from list system, further buttons/links on an application gets activated.

When I tried to automate this in Uipath, first I used to “click” activity and then used a “Select Item” activity. When I run the workflow, the selected item is populating in the dropdown, but the buttons still remain deactivated. What I need to do get this working.

I even tried a click activity along with sending hot key (tab, Enter)

hey @meenal.pathak
Since select item activity work for specific cases.
I would advice you to try set web attribute if it works in your case.

Hi @meenal.pathak ,

In this case, perhaps you should try the Type Into activity + [enter]

Best regards,
Marius

tried, it doesn’t work

if I manually select the dropdown value, it works perfectly fine with just single click

can you please elaborate more? mine is desktop application.

kindly check this one.

thanks, but it is not helping. its by default selecting very first value in list.

By any chance you can share the drop down screenshot? As well your UI selector?

<wnd app =‘xxx.exe’ cls=‘xxx’ title=xxx */>

this is how it looks, id is constant always.

Any chance that you can play with the title using the wildcard * ? If not when you get to drop down does it help if you type the first letter of the drop down options from the keyboard to see if it selects it? You can click on drop down and while active just type the first letter of any items on the list to see if it will be selected.