Can't Select Options in Dropdown

Hi all,

I’m having issues with an internal desktop app. I’m trying to select the options in the dropdown but cannot select the values, using the Select Item activity or the Type Into activity. The Type Into activity works until a special character is typed, which resets the search in the dropdown. See image attached.

Has anyone experience a similar issue and discovered a workaround?

Have you considered using the send hotkey “down” activity to allow a manual selection?

Which special character resets the dropdown?

Hi @ramirezp

Try getting selector of your specific item from visual tree pane in UiExplorer !!
It might help you.

1 Like

Thanks guys. Yes, I have considered the down key. However, this dropdown list is subject to change. Therefore, it may not always be a fixed number of down keys. Also, any type of special character resets the search (i.e. apostrophes, ampersands, etc.). I have tried using the actual selector as well but it did not work.

Any other thoughts?

I would assume you are left then with image recognition. The Computer Vision activities are very useful for this:

You may have to be quite smart about how you can get the correct text to appear on screen through the dropdown so that it can be recognised by the activities. Mabe by entering everything up to the special character at least so as to minimise the results to a few?

Hi @ramirezp

As @ChagantiAkhil mentioned, try getting the selector for one particular item from the dropdown using the Ui Explorer. Then make it dynamic by providing the value you want to select in the selector itself using a variable. That way, every time you want to select, the selector will be created dynamically along with the value you want to select. Then, try using a Click activity to select the value required.

Hope this helps!!

Let know how it goes.

Ok thank you all! I wasn’t able to use the selectors since UiPath cannot identify the individual elements but Citrix Recording with Screen Scrape Relative seems to have worked. I just hope that it will work across machines.

Thank you all!

1 Like

Hi @ramirezp,

Use click for dropdown & select accordingly

Hi @ramirezp,

Have you resolved this issue? I’m having the same dilemma and I’ve tried all workaround but still no luck.


I did have better luck with the Computer Vision package if you want to give that a try


Tried that one too. May I know what specific activity in CV package you have used to resolve the issue in drop down?