Pop up Issue while reading the Outlook Emails

I am getting the error while reading the email from the outlook. There was a popup which shows up and I have automated it using click and select.
My problem is now if I run the Bot from the studio in the DEV or QA Environment, it is working fine but if I run it in Prod from Orchestrator then Bot is unable to click on the popup. It got stuck there and throwing the time out error.

Anyone worked on this type of issue. Please let me know


Check simulate type or send window message property for that click activity and try.

Tried with simulate type also but no use

@lakshman I can get it from DEV environment but I am unable to do it from orchestrator

can you send hotkeys for closing that popup…
I mean if there is any other way from keyboard… try that…


Are you opening Outlook with run as administrator in any Prod environment ?

Hi @sugunakar13 - What type of Pop-up it is? Can you share a screenshot of the same?
This can be a permissions issue like Outlook pop-up is opening with higher privileges as compared to UiPath robot or may be the antivirus/security policies in prod does not allow UiPath to click on the pop-up.
Hope you have tested running workflow in unattended mode in lower environments. If yes then please compare the policies in both the environments and find out the one which can run this pop-up with higher privileges. And disable the same.

If the popup says something about an external program trying to send mails via Outlook, the popup can go away by changing the Trust Center settings in Outlook and allowing programmatic access to external scripts.