PDF Extraction Bug Fix

Is there a fix scheduled for the PDF element extraction. There are posts about disabling accessibility that works for some but it does not work on my system (Windows 10 - Adobe Acrobat DC 19.008). Nor does it work with Nitro Reader 5. Is there a PDF reader that it recommended that it will currently work with? What was the last working version it fully worked with?

Kindly put a note in the RPA training so 3.753 hours are not wasted by trainees.:smirk:

1 Like

I also have this issue. This is a huge issue because reverting back to older versions through the provided FTP download link does not work, as the Acrobat Reader DC software automatically configures itself for updating to latest version, at install, whatever version you try to install. And most customers will not install other PDF reader softwares so I’m completely stuck too!:tired_face:

I hadn’t tried that yet. There must be an automatic update setting to turn off or possibly block it through the firewall?

acrobat reader XI is the last version i have seen working with uipath in my personal experience.
I came here in search of a solution myself for Adobe Acrobat reader DC.

Hi @jmf

According to our documentation, the Adobe Acrobat DC 19 is indeed misbehaving and it is suggested to use versions 18 and below:

I am sure our team is already working on the fix though!

This appears to now be working with the newest Acrobat release:
Tested with the 19.4 UiAutomation pack and AcrobatReader DC 19.012.20040 (latest official build) on several untagged document.
Appears the issue was fixed and the behavior is the same one as it was prior to the breaking change.

  • Accessibility assistant starts only once and preferences are saved
  • Selectors are generated paragraph by paragraph/element by element
1 Like