Orchestrate - Add Queue Item: You are not authenticated! Error code: 0

Hi There,
Today I got this error message after job was Faulted. This has never happened before and when the same job was ran again, got same error message. I had to disable Add Queue activity so that job was finished.

Any one faced this issue before.?

Kind Regards

1 Like


Go to Roles page in Orchestrator and check permissions whether that BOT has or not.

1 Like

As you mention , you are going to try and face this message or robot ?
so anyway , check your user role permission and also robot (if error coming to robot)

permission of JOBS
you have to have “EDIT & CREATE” permission under jobs

Thanks, Following are the permission bot has got. But this was working until last Friday with same permissions.

1 Like

I have now given those two permission to the bot and published it to orchestrator. When the job executes tomorrow we will get to know if this fix has worked. Till now 21000 plus items are added to this queue, but never got error and job had faulted. But anways, lets try this and keep eye on it.

probably , someone would change who has permission for it :wink:

I’m having the same problem adding a queue item in community edition.
Any ideas please.


I updated the jobs permission for the robot, but still get the ‘You are not authenticated message’

Tried adding some extra permissions in the processes, queues and robots also but that hasn’t worked either.

This issue not only applies to adding queue items but also getting credentials.

Looking for a solution to that problem gave me the answer

The issue appears to be to be a problem with UiPath.System.[Activities] from v20.6.1-preview which seems to have various issues regarding orchestrator related activities. If you roll back to v20.4.0 it works. Maybe there is another package that has to be installed? (but you would think that should be part of the standard package set up). Could someone from UiPath confirm that this is a known issue that is being addressed?


What is the solution for this error?

Did the changes as per the above instructions ,still same.Issue is not resolved for me.

I’m not sure if this will help but I had further issues using orchestrator activities recently. It still worked by reverting the systems.activities package to 2020.4.4? But then I reinstalled uipath completely and after that it wasn’t working at all. UiPath Assistant and orchestrator were both showing machine as connected but unlicensed. After various things I logged off the assistant and then I was shown as licensed connected again. These issues may not relate to your problem but here is the post just in case. It now works with the latest activitie package so really I have no idea what resolved it.

Hi @basanth

Please check whether the studio and Uipath assistant and orchestrator has same version,

I faced this before and uninstalled uipath studio beta version i installed 2010.4.3 or 2010.10.2 stable version of studio and assistant. connected machine and robot to
my orchestrator version is 2010.10.2, Now I am able to add queues.



Hi @Latika10011740,
Thanks for the response,

robot assistant-20.4.3 version

Uipath Studio-2020.10.2

Uipath Orchestrator version- 20.11.20-release.61

Could you please help me to upgrade /de grade the version accordingly.

Hi @basanth its because of you have different studio and assistant,

please upgrade your UIPath studio to 20.4.3 version


please upgrade Uipath assistant to 2020.10.2.

Make sure studio and Robot has same version.


1 Like

Thanks @Latika10011740.

Yes, this seems to be a version problem. The exact same problem was resolved for me, after I upgraded all project dependencies in the project based on the REFramework in the Manage Packages section.

Hello Everyone,

I am receiving the same authentication error and have tried all the above suggestions and also read through the forum but no luck. I also could not see any attended robot option when creating User and Robot. Not sure, if this might be the reason too. Please find the below screenshot for your reference.
Appreciate your guidance here.
I am using community orchestrator version 21.4.3.

Please check this thread Getting Error while adding item to the queue - #13 by Sparrow

. I have uipath latest version but i install down grade uipath package which support my development environment , I try to add item in Queue but same error occurred please help me to resolve it .