Office365 integration Move and/or Copy Item (from Sharepoint)

Hi there,

I am having issues with the office365 integration (using uipath.microsoftoffice365.activities) and the move or copy item. It happens with the last version as well as with the previous one.

For some reason it says always “Copy Item: Object reference not set to an instance of an object.”

I have used exactly the inputs as in the example ( and the item is even copied on the sharepoint. So the activity was executed! but is still throws the error.

Its no exception, as I have tried to pass the message with a try/catch with a “system.exception”

Any suggestions?

At the end I have to copy all files from a sharepoint folder and have to upload the end result once finished the task.

Any help would be great
Thanks in advance

Hi @andreas1

Could you maybe share some screenshots of the issue and your current configuration?

As said, the file is moved on the sharepoint, but then the error occures and it won’t be deleted (in fact it just copied the file and then threw an error)

Funfact: also with the copy action, the file is copied but the same error will happen

Could you try debug mode, then using the Step Into button to move from one activity to the other, and to see your variables and how they behave after each action?

Try a Microsoft 365 Repair:

  1. On the Windows Start screen, type Control Panel.
  2. Click or tap Control Panel.
  3. Under Programs, click or tap Uninstall a program.
  4. Click or tap Microsoft office 365, and then click or tap Change.
  5. Click or tap QuickRepair, and then click or tap Repair. You may have to restart your computer after the repair process is complete.



Have you solved the issue?
I have the same symptoms but the error is like “Copy failed” even though I run “Move File” activity. The interesting fact is that it was working one day and then it has just stopped working.
Delete or Upload file are working fine so it cannot be the matter of accesses.

Best Regards,