Move Item Activity - File is not moving to destination folder


Since April 19th (2022) all my robots using the activity “Move Item” from the Microsoft Office 365 package started to fail. The error is: “Copy Item: Code: nameAlreadyExists Message: The specified item name already exists. Inner error: AdditionalData: date: 2022-04-20T11:24:13 request-id: dd143ace-ffeb-40db-83eb-a7149dbc8297 client-request-id: dd143ace-ffeb-40db-83eb-a7149dbc8297 ClientRequestId: dd143ace-ffeb-40db-83eb-a7149dbc8297”.

I also tried filling the input “New Name”. When I do this, the robots continues without problem. But when I check if the file is in the destination folder, I realize it is in the original folder but with the New Name.

I tried updating the packages, and UiPath Studio and the problem persists.

You should put this in Help, not Feedback.

Anyway, do you have overwrite checked? Show us your code.

Sorry, I’m new to this and I am in a hurry. I didn’t even realized it was on “Feedback”

It was working before. I basically move the drive item I’m working on to a new folder that I’ve just created “pastaTratadoHojeBic”. And since the error was about the name of the file, I gave it a new name: originalName_.pdf (original name with an “_” in the end).


When I check the destination folder the file is not there. It is in the original folder with the new name

Have you checked to make sure your path variables have the correct paths?

(post deleted by author)

I am having the same issue with this activity. I have double checked all path variables, as well as if the drive items are being correctly identified, which they are.

The activity seems to be trying to move the file to the (original) source folder and not the destination, so it throws an exception (‘The specified item name already exists’) since the file is in that folder.

1 Like

Yes! That is exactly the same problem I’m having!
I don’t know if Sharepoint got an update and this activity stoped working because of it. Maybe UiPath wasn’t able to solve this issue yet…

This is a known problem with API from Microsoft: driveItem: copy ignores posted parentReference - Microsoft Q&A
Hopefully, they will fix it soon.


Thank you for your feedback!

@DM1 I think it is working now!

I am having the same issue and it is still not working for me

Hi, also having the same problem. Maybe you could update this post, when it’s fixed, or if you know of a workaround for it for the meantime?

It looks like it should be fixed by now by Microsoft: