Not working while unattended

I have made a process that works perfectly when running it from UiPath Studio. However, once I upload it to Orchestrator and try running it on the same machine it says a UI element is not found. I am unable to find the problem. Any tips on how to fix this?

Hi @zackattack0517

It might be because of resolution issue. Kindly update the robot settings as mentioned below.

  • Make sure that the robot is installed in Unattended mode (Service-Mode)
  • Make sure that project is not set to run only in the Background or Attended
  • Make sure that you have at least one available Unattended runtime or a Non-Production runtime in the machine template that your robot user is connected

Hi @zackattack0517

Check out the Thread for more info

Try the Below steps as well as

  1. We should have any on going connections with the VM(bot machine) like user logins. to avoid this we have to restart the VM to make sure that no user logged into this VM machine.
  2. Have you installed the Bot which you are running as un attended from orchestrator by using MSI installer since we must install the bot with service mode since service mode bot is required for un attended automation.
  3. Make sure that you assigned un attended bot license for the Bot(VM) which you are trying to run your process un attended.

Regards
Gokul

I adjusted my robot setting to what is shown in the picture Muthuraman. When it comes to installing the robot in unattended mode I am unable to do that at the moment, due to needing the admin to make the change. However, all of my other processes work on this machine besides this one aspect of this one. I am going to install it in unattended mode as soon as possible. If it works with the other processes does it sound like that may still be the problem?

I found the problem. Somehow I was signed out of my account so it was not publishing to my account. So the version was staying as the same broken one.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.