Not Running Jobs from Orchestator/Uipath Assistan

My processes doesn not work properly from orchestrator/Uipath Assistan. The process in Uipath Studio works just fine, but it does not in Orchestatror or Uipath assistant.

It appears this message (In Spanish) in the bottom area of Uipath Studio, I dont know if it has relation with not attended robot.

Translation:“Unattended robot detected as license type. Under the terms and conditions, this license should only be used to troubleshoot problems.”

Does anyone has the same problem??

Thanks in advance!!

I think the prblem might be here:

Any help?

Thank You!

1 Like

This message in Studio is indicating that you are using a Unattended License to authorize Studio which should only be used to help you troubleshoot your processes. In normal circumstance Studio should be authorized by using a Robot of type Studio.

Please check the status of your Robot in the UiPath Assistant. If you hover your mouse over the status i.e. Offline then it will provide a less ambiguous message.

image image
image image

This will help to identify what you should be looking at. For example “Robot does not exists” could be a few different things, but most commonly I see on the forums that the username provided to the robot is not in the right format.

3 Likes

Try connecting Robot type as “Studio” instaed of “Unattended”.

1 Like

Please note that in modern folders you can assign both attended and unattended license to an user.

That warning targets the enterprise. Maybe we should remove it in community.

2 Likes

Thank you for your answer!
My Uipath Assitant/Robot it appears with green light so it is correctly connected, and when I run the process from the Assitant it seems like it is working, but it doesn´t run the process.

I already tried, but when I connect my robot with Studio instead of Unattended, it does not appear the robot in the field to run the process.

Thank you for your help!!

Manuel.

@Mcaballero50

Can you please:
1.Disconnect robots in Orchestrator
2. Restart UiPath Studio and Orchestartor
3. Create a new Service
4. Provison Robot, Machine. Select Robot type as “Unattended”
5. Add Package, Environment ,Process and then run the Job.

Thanks

Disconnected.
Restarted Uipath Studio and Orchestrator.
Created new service with new name in Orchestrator.
Created New Robot (Standar) as unattended.
Connected with uipath assitant, etc…
New Process published from Uipath, new job, but I cannot choose a robot

These are my settings in the New Service, Do I have to change something?

image

And these are my setting in the Robot of Orchestrator:

So I chose my process, and cannot select robot even though it is connected in Uipath assistant.

@Mcaballero50 ave you done this? You can not schedule a Studio robot. Only Unattended.

Everything seems to be fine now, I see my robot when I go to Jobs, but I ran the process from here, not working, I ran the process from Uipath assitant and it does not work, and I run it from Uipath Studio and it runs perfectly.

I dont know the problem.

Can you please check couple of things:

  1. when you launch UiPath studio do you see “Unattended Robot” as license type (see attached picture)
  2. what is Orchestrator URL you have supplied ?

Thanks

  1. Yes, this is what I said in the beginning of this topic I still se “Detected Unattended Robot as the license…”
  2. https://platform.uipath.com/manuelcaballero/Manuelrobotuno/

About the URL, do I have to change some setting in Uipath Studia itself? I checked in the software but I dont see any option to change URL for orchestrator, in fact when I publish from Uipath, it appears the process in orchestrator properly…

The URL looks good.

I think I solved some of the problem, and it seems my robot is connected. What I did is my machine name in Orchestrator is the same as my machine name in Uipath Assitant, so My robot it appears now as available.

But I run the process from Studio and it works, but not from Orchestrator.

I am having the same problem. My ‘Unattended’ robot is picking up in Orchestrator and I can successfully run a job on it however the job ‘flickers’ but it doesn’t run, it’s like it’s crashing. It runs in Studio. I’ve only just set everything up for the first time so it’s a basic Message Box job. I’m fairly tech savvy so was expecting it to be a simple process to get this up and running.

Any ideas?

In fact this isn’t just from running the job from Orchestrator… if I use the Robot/Agent to run the task it looks like it tries to run, flickers for a split second, says it ‘ran successfully’, but the process doesn’t actually run. I’m trying a MessageBox and a file write process and neither work.

The process runs fine when I run ‘Debug’ inside Studio on the same computer. So it appears to be an issue with running the process through the Agent. Is it some sort of permission issue? I can’t see anything about it on the forum or help videos.

I still hace the same problem, it seem like Robot/Agent is working and it apperas like the the process went trough correctly but it does not appear any of the result I am looking for from my sequence in Studio.

I got this answer from an User, look the link, but I am not sure what he is saying to do in Task Manager, I dont get what he gets…

You may try to look for this post, what it seems to be a mistake of user in the machine, I am still trying to figure this out:

We´ll see If I can get this problem solved.

Thanks.,

Some clarifications:

  1. You want to run the process from Orchestrator => you need Unattended license (don’t worry about the warning)
  2. You want to run it from tray/agent => Should work the same as in Studio as long as you have deployed the latest process in Orchestrator.