Robots are not displaying in Orchestrator when trying to run a Job

Hi Community!

I have been using Community Orchestrator for a long time, with several processes running in two different Machines (each with Studio Robots).
But suddenly, when trying to run a new Job from Orchestrator (and / or through the API), there is no available Robot to chose. See the image below:

When using the API to start a new Job, the error message is “Undefined robots” #1678.

I have already checked that the robots are connected and licensed. Tried disconnecting and reconnecting several times.
I am still able to publish packages from Studio to Orchestrator, and to run jobs from Orchestrator through the Desktop Assistant.

Is there a known error that generates this problem? Anyone else experiencing something similar?

Hello !
Did you check if you setup your robots in the same environment as the job?

1 Like

Hi @Lwissitoon Thank you for your reply!
Yes, I’ve checked that. I also created a new environment, added robots to that environment and created the process in that new environment to see if that could solve the problem, but didn’t work.

Check the robot type if is unattended is not change to unattended and then retry.

1 Like

The two robots with which I have always worked are attended, they run in two machines that have UiaPath Studio installed (I’ve used this setting for at least one year).
Did something change in the last two weeks in Orchestrator that could broke how it was working before?

Thank you again for your time!

This changed with Orchestator 20.3. You can no longer trigger jobs from Orchestrator for Robot of type Attended which includes Studio. You will either need to use UiPath Assistant to start a process locally on the host, or switch your Robot type to Unattended or NonProduction (which is not intended to license Studio and will present a warning notice when starting Studio)

This was announced in the following post which was also pinned to the the top of the forums From March 16th until March 30th.

Important . Starting with this version, you will not be able anymore to start a process from Orchestrator on a Robot of type Studio. In order to start processes from Orchestrator, you should use an Unattended Robot. Each Community account has 1 Unattended Robot included.

if you search the forums for similar topics, you’ll probably find a decent amount reiterating these details.


Thank you @codemonkee. It is working now. I have not read about this change.

@codemonkee, thanks!)

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.