Not able to type password in Putty

Hi

I am not able to enter password in putty. I am using "Type Secure Text’ activity to enter the password. Before passing password to this activity, I have converted into secure text also by using - new System.Net.NetworkCredential(string.Empty,“myString”).SecurePassword and then assigning it to a variable using Assign Activity.

Now problem here is as Bot is not able to enter password on putty and it is just coming out of the flow without giving any error also…
Screenshot has been attached for reference of the sequence of the activities.

EnteringpasswordOnPutty

Hi @EAP,

One thing is that putty cannot show the password you entered , I mean, it doesn’t show anything in the password field while you are entering. May be , you have to give some delay time before entering password and also clicking enter key to resolve this issue

Hi @HareeshMR

I knw, putty doesnot show anything on screen while entering password. Could u please help/ guide me which activity I can use to get pwd entered on putty.
I have tried removing delay time also as you suggested, but no luck… :frowning:

Just try alternative way of opening a file and copying the password from the file. Use the right click activity so that the copied password be pasted in the password field. then send the enter hot key.

Hope this resolves the issue.

hi @EAP
i am new to uipath
i am also using putty
and want to automate putty via uipath
so how can i enter username on putty after opening putty with ‘open application activity’
i am trying to enter username through type into activity but its not working properly
suppose username is ubuntu
it is typing [3~ubuntu
any help would be appreceable
thanks.

Hoping that you are making successfully connection with putty first by entering hostname etc.
Just try,using Click activity before Type into, so that the focus comes on to the putty screen.
Also verify that Activate property is also checked for Type Into activity.

let me know, if still not works

hi @EAP
thanks for the help
but i figured out what was the problem.:grinning: