I can't find Type Secure Text for password input

Hi, Forum

Where Can I find the “Type Secure Text” activity?

I can’t find UiPath.Core.Activities from anywhere, either.

Thank you for your help in advance.


Hi @HongJoo_Choi

Type Secure Text is an classic acitivty
You can find it by enabling classic filter in acitviities panel.

or you can type this in assign activity:

(New System.Net.NetworkCredential("","give the password here")).SecurePassword 

The output DataType would be System.Security.SecureString

Hope it helps!!

Kindly note:
nowadays we can do:

Hi, @ppr and @Parvathy

Thank you for your help but could you help me once more?
It seems like the classical Type Secure Text is incorporated into modern Type into according to the comment.

Anyhow, I’ve tried to input password by using both Type into and Type Secure Text, but failed.
The variable “Password” is obtained from the Get Secure Credentials and put into the input field of the Type into.

What should be property settings look like for Type into?

I’ve tried with default setting first, and then set Input mode to Hardware Event alongside the keystroke delay set to 0.1 second, which didn’t work.

Your help would be much appreciated.



Isn’t the password not being typed. Specify. Try keeping the input mode as Same as App/Browser and try once. or once try giving Delay before and try. Check the selectore if still not working try running the workflow in debug mode and check how much time it’s taking to type according to that give that time in Delay Before of TypeInto.



Is the right elment being highlighted while debugging?

In the debug panel select highlight element and check …

If the right one is getting highlighted then use a click before typing option in the type into and try


Hi, @Parvathy and @Anil_G

I’m afraid, none of them did work.

Tested one by one with input box getting highlighted and clicking before typing in, input mode set to “Same as App/Browser”, putting some delay before typing in. In all these cases, the password is not even typed in.

This is a public site therefore you can check it by yourself, if you would like.
개인로그인 - 우리은행 (wooribank.com)

or you can access the page as shown below.

NOTE this is a banking site therefore it’s safe enough and no need to worry about malware infection.

Best regards


Verified the same…looks like the security settings of the site is preventing from using UiPath to type it…I event tried inspecting the element but it is not allowing

Looks like the security features that are mandatory to download are blocking