Not able to install added extension to UIpath

.exte
I have installed chrome extension for UI path to start web recording.But after installing from
tools->chrome ,enabling extension and restarting browser, I’m getting alert that it isn’t installed. I can’t install it via command prompt as it’s showing ‘setExtension.exe not valid command’. How can this be resolved?

Does your organization have a Group Policy that prevents installation of non-whitelisted Chrome Extensions? I have seen this strict policy in some companies.

Hi @Gopalakrishnan_K

try installing using below link :-

Hope this would solve your issue :slight_smile:
Mark as solution and like it.

Happy Automation :raised_hands:

Best Regards
Er Pratik Wavhal :robot::man_technologist:t4: :computer:

Hi @ Pratik_Wavhal,
It isn’t quite working for me.It’s showing same alert message for me.Can you say why it is? I am using UI studio pro version.Is there any difference between pro and pro community version?.

@Gopalakrishnan_K

Can you check with your company admin, as there is some policies which will restrict installing other add-ons, if that is then you have to get it solved by admin only

There is no difference between community pro and pro, all we have is in pro you can install components like orchestrator separately, but community it is not possible

Hope this helps

Thanks

Hi @ksrinu070184,
Admin says that there isn’t any restrictions . I have enabled developer mode, incognito mode and access to URL options in extension. I have tried solution as https://rpageek.com/uipath-chrome-extension/ but it isn’t working for me.Is there any way to resolve?

we do not have any such setting at present on an organization level. Also this issue isn’t seen on another user who installed recently.

Any other suggestions on what could be wrong? All settings mentioned in the below link have been checked:

Hi @Gopalakrishnan_K
So the UiPath Chrome Extension is installed and enabled on Google Chrome but you’re unable to record your user activities in Google Chrome and able to identify selectors.

I have seen this before and this issue was caused by “Chrome Native Messaging Host (32-bit)” not launching when Google Chrome is running. When you launched Windows Task Manager do you see “Chrome Native Messaging Host (32-bit)” as seen in the below screenshot? It should be a child process of Google Chrome.

image

If “Chrome Native Messaging Host (32-bit)” is not launching, this could be because the registry entries were not created properly. The RPA Geek article to you saw gives instructions to solve issues with the old version of the UiPath Chrome Extension.

To resolve the missing registry entries, launch “regedit”

Make sure to add a new key:

HKEY_LOCAL_MACHINE\Software\Google\Chrome\NativeMessagingHosts\com.uipath.chromenativemsg_v2

Default – REG_SZ - C:\Program Files (x86)\UiPath\Studio\UiPath\crx_manifest.json

Of course check if the crx_manifest.json is indeed in the directory indicated above.

If the UiPath Chrome Extension was not installed when you ran UiPathStudio.msi and instead was installed through UiPath Studio, the location of the crx_manifest.json would be in “C:\Users<user>\AppData\Local\UiPath\crx_manifest.json”

If indeed the crx_manifest.json is in the User’s APPDATA directory as indicated above then the registry entry should instead be configured this way:

HKEY_CURRENT_USER\Software\Google\Chrome\NativeMessagingHosts\com.uipath.chromenativemsg_v2

Default – REG_SZ - C:\Users<user>\AppData\Local\UiPath\crx_manifest.json

If your organization is an enterprise customer of UiPath, you should also open a Technical Support ticket. The UiPath Technical Support team can help you further troubleshoot your issue.

Here the URL to the contact form in the UiPath website where you can raise a Support ticket: https://www.uipath.com/company/contact-us/contact-technical-support

@Gopalakrishnan_K even am facing the same issue . may i know whether your issue is been solved?

@Satishkumar_Bansode,
It didn’t work for me.I tried for Firefox and it worked. Could you try adding extension to Firefox,Edge or IE?

@Gopalakrishnan_K yes its working for other browser but not working for chrome.

@Satishkumar_Bansode,
84.0.4147.125 64-bit. It is up-to-date

@Gopalakrishnan_K chrome extension is working for me know. please check your environment variable setting .