No automations are displayed in UiPath Assistant


For some reason my assistant cannot display any automations all of a sudden

All did work perfectly, I log in using a machine key and log into my account and yet no automations shows in the Assistant.

Is there something I do wrong? I am connected and licensed according to the status of orcehstrator.

Hi @Paul_Andrei_Turcu

Where you are publishing your automations, Is it to Orchestrator tenant Feed or Personal Workspace?


HI, is the tenant and i only have 1 wich is the default

Hi @Paul_Andrei_Turcu

When you Publish your process publish it in Orchestrator Personal Workspace Feed. after that in the assistant you will be able to see the process which you have uploaded.

Hope it helps!!

@Paul_Andrei_Turcu Hi, You need to publish your studio process to Orchestrator Personal Workspace feed and the published package will be displayed in the Orchestrator My workspace in packages folder.
Then you need to create the process with the published package. Then the process will be displayed in the UiPath Assistant.


I have many folders created on the tenant where I have published all my projects before and all of them were displayed in the assistant. How comes now I can only use 1 folder?

@Paul_Andrei_Turcu You can have many folders created in the Tenant. In that case, if you want to run the process from the particular folder in orchestrator, then you can publish into Orchestrator Tenant process feed. Then the package will be displayed in the Default tenant. Then you can create the process in the required folder by selecting the package.

Also check whether the tenant is connected properly to the assistant with Proper organization.
Try logging out from UiPath assistant and reconnect.

So long storry short I am connected using a machine key and it gets the green light when i m connected.

I tried few times already to log in/out and no results.


When you publish your process to Orchestrator Personal Workspace Feed it will display in your assistant. If you want to run from a specified folder. Click on that specified folder under Processes click Add process and add the process you want to add. It will get added.

Hope it helps!!

Dude I ve done this 1000 times already, I have planty of packages published to tenant and many processes on many folders created and yet for any reason all of them are gone from Assistant and I cannot runt hem attended


Can you send the screenshots if possible.

  • Provide a screenshot from Orchestrator → Tenant → Settings → Robot Security

  • Are you using a machine key from a Standard machine or from a Machine Template?

  • Did you add these roles for your impacted robot/user account in Orchestrator?

    Allow to be Automation User at the Tenant level


    Automation User at the folder level (in the folder where the process is present)

  • Is your Machine Template present in the folder where the processes are?

  • Your robot is present in the Automation Express group?

  • Show a screenshot from the Home page of your Studio (we need to see the bottom left side corner)

  • Is your robot added/present in a Classic Folder?

So I have signed out as machine key and logged in as ClientID and same results, all processes kinda loaf on assistant for 1 sec and then it vanishes and only ones from my workspace are visible.


Machine is also present in any folders and so but for no result.

The Studio prom prev pose is on my workspace, the one where I have all the automations published on a vm looks like this


Try clearing cache and restart Assistant by ending the task in task manager and start again.

Thanks, I ve done this already and even changed the workstations from Remote/personal etc yet same result


Ensure that the automations you expect to see in the Assistant have been successfully deployed to the machine where you are running the Assistant. Check the deployment status in Orchestrator and verify that the correct version of the automation has been published to the correct environment and machine.

If it’s not help try reinstalling the assistant.

I just logged my acc on my colleague workstation and I can see all.
It is a bug of UiPath?

Consider reinstalling the UiPath assistant to ensure that you have the latest version and that any potential installation issues are resolved.

worked or not but i added 1 more account with exact same right as my other acc and it displayes all on assistant. I didnt reinstall anything