Published process to tenant feed aren’t showing up in UiPath Assistant

Hello and thanks in advance for the help,

I’ve published two process to tenant feed but they aren’t showing up in UI assistant. I am using orchestrator SSO, will I need to use machine key? Previously I have been using SSO, so not sure why the UI assistant processes just disappeared.


when you publish a project they give you some options, one of these options is publish to my personal workspace, so they appears automatically on your assistant


1 Like


For now, can you check the following?

Is there the account or group which the account belong to in Tenant -Folders : Shared folder - Users.

Does UiPath assistant connect with the Orcehstrator tenant correctly?


UI Assistant is connected.

Groups set up for shared folder and I already assigned my self to all of them but still nothing in Assistant.




May I know what license is assigned to the machine and the user


Automation Developer


Could you please give attended user license to the robot


It’s been like that, still nothing.

Maybe just to be certain, could you take a screenshot of the groups and users assigned to the Shared folder?

Please make you have attended license activated for your machine and in shared folder you(as user) and require machine (in case yours) is properly added. If you find this is already done then please logout UI Path assitant and login again

Two users. I only need to add a machine if I need to run an unattended bot so there is nothing in the bottom section.

Process is published as attended.

Bump, still having issues with this. Thank you very much in advance

Hmm so just to be sure:

  1. You’re connected to UiPath Cloud, correct?
  2. Can you confirm that the Orchestrator is in the same Cloud organization and UiPath Assistant is connected to?
  3. Can you confirm that there’s only one Tenant in the Cloud organization where you’re creating these processes?

1 & 2. Connected with SSO

  1. Only one tenant

@BTU for each of the users did you enable personal automations?

Orchestrator - Enabling Users to Run Personal Automations (

Confirmed, still no process in UI Assistant. Thank you for trying!

Well that is indeed a mystery. Have you tried reaching out to UiPath support?

  1. After the process was published to the Orchestrator Tenant feed, you need to go to Orchestrator → Modern folder → Processes → Add process → find the published process → Create

  2. Add the attended/unattended robot/user to the folder where the processes are present and need to be executed

  3. If you choose in Assistant to connect via a Machine Key or Client ID credentials, you need to add also the Machine Template to the Modern Folder where processes are

  4. For the Robot users that need to execute the automations, assign the following roles:

  • Allow to be Automation User at the tenant level;
  • Automation User at the folder level.
  1. If your robot/user is present already in Orchestrator, make sure that in Orchestrator → Tenant → Manage Access → (for Attended robot) in Personal automations setup check the Enable user to run automations → (for Unattended robot) in Unattended setup check the Allow unattended robots to run automations as this user and select the Use a specific Windows user account. Add credentials below (DOMAIN\USERNAME and windows password) → Update

More details here:

  1. Disconnect the robot from Orchestrator from UiPath Assitant and reconnect back it into the correct tenant in case your user is present in multiple tenants

  2. Also, unassign the user from the Automation Express license or unallocate the Automation Express license from the other User groups as it will give access to run automations only from your Orchestrator personal workspace.

More details you can find here:

Let us know the outcome.