Need assistance with automating legacy application (Check box) in UiPath's Community forum


I am currently automating a legacy application that needs to run continuously, even in a locked session on a remote desktop server (unattended mode). However, I have encountered an issue that I’m unable to resolve on my own.


The problem lies in clicking the “Select All” option in the column header of a top-level window using either a Windows message or simulation.


Whenever I run the automation, it clicks outside the small rectangle box and proceeds to order the elements in ascending or descending order, without actually selecting the checkbox.


Here are a few details to consider:

  1. Input mode: Hardware successfully selects the checkbox.
  2. Activities such as “Select Checkbox” for both modern and classic modes result in an error, stating that the desired checkbox UI element is not found.
  3. Unfortunately, there are no available hotkeys to perform the checkbox selection.

I kindly request your help in identifying and selecting the target UI element for the checkbox.

Thank you for your assistance. @UiPath_Community


Did you try using click with offset?


Try playing around offset to click properly


@Anil_G Thanks for prompt reply. As Simulate click cannot be used with Cursor Position. And windows message did not click the desired uielement. Thanks as I got to know new properties today. Help me if there is any other options .
#HappyLearning @UiPath_Community

@Anil_G You can check the attributes of uielement here.

That’s not going to work. When it’s locked, there’s no UI for UiPath to interact with. This is just how Windows works. Why does it need to be locked? You don’t run unattended automations by logging in, starting the job, then closing the RDP window. Orchestrator creates its own RDP session to run the job in.

As for the click issue, have you tried the Check/Uncheck activity instead of Click?

@postwick Thanks for prompt reply. The process is designed to run in schedule based. If I use hardware as input method then it throws the exception like cannot bring the application to foreground.

Check/Uncheck through the error

Any other ways? @UiPath_Community

That’s what Orchestrator is for.

That’s because you have the session locked. That’s not the correct way to be running unattended jobs. You set up Orchestrator and the robots, and schedule the job in Orchestrator. It will establish its own RDP session and run the job.


How about using classic ClickText activity (or modern NClick native mode) with CursorPosition as the following? Please tune offset settings.


@Yoichi In my case what will be the target uielement text name as the uielment is just a rectangle.
Thanks for your valuable time. @UiPath_Community

@postwick Yes Exactly I want to establish its own RDP session and run the job. I have used around 60 activities for this process and every activities is either send windows or simulate. And it is perfectly working without any issues.
Do you have any idea how to deal in this situation.
Thanks for your valuable time @postwick @UiPath_Community

I think the target will be the following red rectangle then text is “Request” and offset TopLeft, X:-20, Y:5 for example
Please check where mouse cursor moves and tune the above settings.



@Yoichi Tried since 1 hr. and no any good news. As simulate input method is not support on Cursor Position and Windows message just hover the element and couldn’t click it. I confirm the cursor position by using hardware as input method and smooth in properties. It was right on the center of target.

Please share if you any other ways. I need to select all the list at a once.
Thanks and regards


For now, can you try classic Click Text activity?
(If it’s necessary to use modern click, we need to indicate element with native mode because if we set selector and native text, selector is prior and click center )


No classic click text activity did not work too.
Thank you @Yoichi Need to try new things

@gibl.rpa if you cannot check the checkbox from header try selecting all check box using while loop and tick using dynamic selectors (make table row dynamic).

1 Like

Yes it works But taking few seconds while ticking one by one. I guess for each parallel process will work for me .

Thanks you @Ganesh_Tiwari1


You configure Orchestrator to run the job as an unattended process. That’s a bit more than I can explain in a forum reply. If you don’t know how to do this, I suggest reaching out to your UiPath rep for some assistance.

You can do a small macro or vba solution to it, that couldowrk well, since this check box is just an object on the cell ref.

1 Like

I am already running the process in unattended mode.