Issue running web automation in unattended mode on vm

Hello community,

We have developed a web based automation which runs fine in attended mode on windows virtual machine but when we try to run the workflow in unattended mode it throws web selector error(couldn’t able to identify random web elements). I have tried various solutions provide by the forum such as screen resolution change etc. nothing worked for me.

Below are my question:-

  1. Is this a common issue with UiPath Web automation?
  2. How to avoid this issue as we can’t run the business use case’s in attended mode?

Regards,
Subham Srivastava

For what activities you are receiving the errors? Does simulate click has been used for all the click activities? identify which activities causing the issues and search forum with error message you are receiving.

Hello Swavas,
Thanks for the quick reply. yes we’re using simulate click and as mentioned above the workflow runs smooth in attended mode but fails to identify the same web elements when running unattended.

I have tried various solution provided by forum but nothing worked.

Regards.

You are more specific to which activities causing the issue some one can help you, if you tried all options and still unable to resolve the issue, please contact UiPath technical support team they can help you.

As i have mentioned the selector error are random. Most of the time it’s the mouse click activity/send hotkeys which couldn’t identify the web element while running unattended.

Note: i can’t take support from UiPath technical support team as I’m working on premise. we use machine key instead license code.

Just to add on Contacting support part, you need license key regardless of machine key. Please check with in your team or manager. with out license key you can’t run any of your process in UA mode in on-premises.