My Robot status is Disconnected

Please help me to connect my robot and run the jobs.
UiPath Studio Version 2021.10.0 Community Licence


MyUiPath assistant shows No Processes

I have tried many ways but it did not work.

Kill all the instances of the Assistant from the task manager.

Close if any studio instance is there.

Then open the assistant and you will be able to see the status, if not online → Go to preferences and then add the machine key and URL to connect

Also suggest you to confirm the credentials in the Orchestrator too. Better add it again.

Hope this helps!

Open your UiPath Assistant or UiRobot if using Legacy and hover your mouse over the Status field. This will reveal a more in-depth status and help to isolate what you need to look at.

image

image

image

image

As an observation, your user is set as corp\sbawariy, is your domain corp? If not, double check this by running whoami on the command prompt.

Any other suggestion would be just guessing until we know what status your Robot is in, but some thoughts

  • Ensure you have allocated licenses to your Orchestrator from the Cloud Portal
  • Ensure you have allocated Runtime licenses to your Machine

Once you have a Robot that is showing Connected / Licensed, if Orchestrator isn’t reflecting that, then you’ll probably have a mismatch on Machine Key of your User Profile compared to the Classic Robot.

Classic Robot should override a Modern Robot unless you had already connected it with the Modern Robot before creating the Classic Robot, in which case a simple Disconnect/Reconnect of the Robot should suffice.

Once connected with the Classic Robot, you’ll want to ensure that you have a process that is published to the same Environment that the Classic Robot is a member of

Credentials won’t come into play until you actually try and run a process. Even with invalid credentials or just a username the Robot should still show Connected and Licensed from Orchestrator and Robot.

^^ bob/code is not my domain or username, but you would get a The user name or password is incorrect. (Exception from HRESULT: 0x8007052E) when you attempted to start a process with that same robot.

i have tried after killing all instance of Assistant, The Assistance is online again
image
.
Also I logged out from Orchestrator and Assistance and logged in again.
Still my Robot status is Disconnected.
i am also not able to find Robot in my system while searching via Start->Robot but not getting any results.

Sometimes I am getting below message
image

  1. I have checked again with whoami found the same usernamecorp\sbawariy,
  2. what status your Robot is I cannot find Robot in my system while searching via Start-> Robot did not get any results.
  3. Could please you let me know where I can check below things:
  • Ensure you have allocated licenses to your Orchestrator from the Cloud Portal
  • Ensure you have allocated Runtime licenses to your Machine

Sometimes i am getting below message
image

did you try interactive login?
you logged in to the cloud portal to get the assistant online?

If so, you can delete the robot instance you created with that machine name(what i can see on your first post), because there will be an instance created for your user account, in your orchestrator.
You can manage that user to give the license that you need for your system.

Recommend you to go through the below doc to understand how that works

1 Like

From your screenshot, the green shows that it is connected, but you can open your User menu (The SB), or right click on the UiPath Assistant Tray Icon and go to Preferences > Orchestrator Settings.

Depending on if you are using Interactive Sign-In or not, the Connection Type will be different, but should provide a Status message similar to if you hovered over the green icon on the main window. Hovering over the Status message here will provide a more detailed message as I show in my above post.

If you are periodically seeing this message with no changes by you when it occurs, you might have a network issue (or something interfering with the communication) as once it is connected heart beats are sent between your Robot and Orchestrator for a health check.

In my setup I have Robot installed and registered as a service, so typically the only time I ever see that message is on bootup and the Windows Service for Robot hasn’t started yet as it is delayed.



Question for you:
Are you trying to associate the Unattended Robot with your user, or are you just wanting an Unattended Robot?

From your screenshot it looks like you are attempting to create a Unattended Robot in a Classic Folder, but if this robot’s credentials is the same as your User’s Robot and your User’s Robot was connected first (before the Classic Robot was created), the Classic Robot will not take precedence.

Go to Tenants > Robots and review each of the tabs here.

If you intend to use Modern Folders make sure you are not configuring a Classic Robot, and instead configure your User and enable Unattended Robots for it’s profile Tenant > Manage Access > Edit (On desired User) > Tab 2 Robot Setup > Enable/Disable Robot types as desired.

If you intend to use Classic Folders / Robots and the Robot matches the Username of the Attended User, then disconnect the UiPath Assistant, configure your Classic Robot making sure it has the right credentails, then go back to UiPath Assistant and Connect it to Orchestrator using the Machine Key for the Classic Robot.

Perhaps share some more full screens for UiPath Assistant’s Preferences along with your Tenant Robots, Folders, Machines, Users, etc. and we can provide better information that is unique to you.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.