Keep failing to connect Robot to Orchestrator


I’ve been trying for 2 days to connect Orchestrator and Robot and still keep failing to do that. I’m using the standard Community Edition. This is what I do:

  1. I opened UiPath Assistant and logged in to Orchestrator through SSO. It shows “Connected, Licensed”.
  2. I go to Orchestrator on

What should I do next?
From what I understand, I should:

  1. Create a machine.
  2. Create a Robot tied to this machine.
  3. Create an Environment.
  4. Upload a package from Studio.
  5. Run it.

How I create a machine:

  1. “Add standard machine”
  2. “Name” from the whoami command.
  3. Unattended → 1.

Then I go to Robots:

  1. “Default” → “Robots”
  2. “Add standard robot”
  3. “Machine” → select the previously provisioned machine in the drop-down list.
  4. “Type” → Attended User

It always shows it’s disconnected. What am I doing wrong?

The next steps makes no sense unless Robot is “Disconnected”


Welcome to our UiPath community.

Provide below mentioned Cloud Orchestrator.

And select Robot type as Unattended BOT.

Hi @mgm,

In the screenshot, you are selecting the type as “Attended user”, it should be “Unattended” as you created that machine with unattended license.


@lakshman , @sonaliaggarwal47 , same result:

It’s still Disconnected

@sonaliaggarwal47 , @lakshman , thank you for your help but the result is still the same. I’ve also tried to configure it like this previously but it wasn’t working anyway. Maybe this is a higher level problem - in configuration of tenants/admins?

Hi @mgm,

Have you tried another way of connecting to orchestrator via assistant i.e. by using machine key and orch URL?

Could you please try this method.

Also, can you show the screenshot of whoami command from cmd prompt and the one that you have entered in orchestrator?

Also, under tenant->licenses tab, could you go to unattended section, and share the screenshot of status of your machine in there?


@sonaliaggarwal47 , I had indeed tried it before but faced some errors and decided to put away this method. I’ll probably try it again

Hi @mgm,

Yes please try it that way and let me know if it worked.

It should work.