Multiple Entry Points Package is not Supported

Hi,

I have created an unattended bot. After creating a process when I am trying to start a job. I am getting the “Starting jobs for the process which uses multiple entry points package is not supported. (#1697)”

What shall I do to resolve this issue?

Please find the screenshot below:

Hi @Pankaj_Singh,

I ran into the same issue you did. I believed that I had found the solution to it, but it looks like this is a bug on UiPath’s part that needs to be addressed. Let me start with some steps of how I got this message, how I thought to resolve it, and the error that remains:

  1. Before publishing a package, I had designated a specific .xaml file as “Main” by right clicking and selecting “Set as main”

  1. I then published the package to orchestrator, created a process, and tried to run it. I was met with the same error as you – “Starting jobs for processes which use multiple entry points packages is not supported (#1697)”

  2. I went back to my project, and disabled the entry point for the “main.xaml” and then published the package again.

  3. When I updated the process and tried to run it, I still received the same error message.

I even published the project under a different project after ensuring that there existed only one entry point and I still received the multiple-entry points error message.

My plan is to submit this as a bug to UiPath

Can you please tell us what Orchestrator version you are using?

I am using version 2020.4.1

The fix for this was done in the latest 20.4 patch. If you want to continue using Studio 20.10 with Orchestrator 20.4, you will need to upgrade Orchestrator to the latest patch. Alternatively you can continue to use Studio 20.4 with your current version of Orchestrator.

3 Likes

Excellent, thank you!

try to upgrade 20.4.3,

so far I have no problem.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.