Move outlook mail error

uiautomation

#1

Hello,

I am trying to move my outlook emails to specific folder, it was working fine on my local machine but I moved the bot into Production but in Prod machine it is giving me a weird error as mentioned below. Please do help me get rid of this error asap. Thank you.

Move Outlook Mail Message : The items were copied instead of moved because the original items cannot be deleted. Unknown Error."
level: "Error"
logType: "Default"
timeStamp: "2018-04-30T10:34:52.2641878-05:00"
fingerprint: "464009a1-38d3-459e-861e-b6ba90fcd4cb"
windowsIdentity: "LOVES\de.ardmore"
machineName: "RPA-ARDMORE"
processName: "DTN_Loves_PROD_MAIN"
processVersion: "1.0.6694.18961"
fileName: "Main"
jobId: "0a67d89a-f6ea-45f3-b4c9-5dee6b15e9c3"
robotName: "Ardmore"


#2

Hello!

Have you tried to do it manually to see if the error appears? Are the Cache Mode active?

Regards,


#3

I have tried it manually and it works perfectly if I run it on my Local machine but I am getting problem on my Production machine


#4

Does the production machine (or the account the process is executing under) have the same rights to the mailbox that you have? Could it be a security/permissions issue?


#5

Check if the mailbox is with Cache Mode ON


#6

I have tried it manually but i was not able to move the mail messages in to another folder.

Do you think that might be the problem??


#7

Thanks for your reply,

Where do I check ??


#8

It sounds like a permissions issue but keep in mind I’m no expert. Are the accounts maintained by your IT department? It sounds like you may need “delete” or some similar level of access granted to whatever account needs to move the mail message as the server recognizes moving of the original item a delete action on the original. The link below may shed some more light.

https://social.technet.microsoft.com/Forums/ie/en-US/5046d89d-64a2-44cc-a536-2c1231b0cc68/users-cannot-move-email-messages-within-outlook-shared-mailbox-inbox-and-subfolders?forum=exchangesvrclientslegacy


#9

Thank you so much Sir appreciate it


#10

Hello Williams,

Bot has been granted permission to move mail from one folder to another, I have tried doing it manually in the prod environment. But when I run the same thing with Bot in Prod environment it stills gives me the same error as mentioned above.

Is there any alternative for this. Please help.

Regards,
Raviteja.


#11

After the bot was granted permission was a reboot of the machine or session performed? Maybe the permissions haven’t fully applied yet? If you are able to truly move the email on the production machine (using the same credentials as the bot) and not just copy it (as the error says) then it seems strange the bot wouldn’t be able to and generate this particular error. Maybe the error message is just misleading…


#12

Thank you for the reply Sir,

When you say “permissions haven’t fully applied” what do you exactly mean by that??

i have rebooted the system twice, even though there is no change in the error.

Please advise.