Message: Error opening workbook. Make sure Excel is installed - unable to fix

Have just started Lesson 9 of the Level 1 Foundation training , things have been running smoothly, but have come across an issue opening excel files using the default

Unable to open any excel file, (unless reading a .csv) using the inbuilt Excel Application Scope command.

image

Running Office 365 Pro Plus, and have uninstalled and reinstalled a number of times, no issues opening any file with Excel normally. Also tried repair option on the installation

Running Community Edition 2019.7.0 of UI Path, and have unstalled and reinstalled, so just running default packages at this point.

Running Windows 8.1 Pro, with all current patches.

Have searched the forums, and tried to edit the registry to no affect , and do not have any prior version of Office/Excel installed on this computer.

Please help, as our local UI Path expert has been unable to assist.

Regards,
Shaun

1 Like

Hi @Shaun_Lockwood,

Have you tried installing Excel.Activities?
If not, please do so and see if it works.

In your ribbon click ‘Manage Packages’ and search for Excel.Activities.

Regards.

No worries
–Kindly go to Design tab -> Manage Packages -> go to project dependencies
and upgrade or downgrade the UiPath.Excel.Activities package
–or uninstall and reinstall that package
–make sure that once after reinstalling the studio is restarted

Cheers @Shaun_Lockwood

Good Afternoon,

I have tried the suggestion - uninstalled UiPath.Excel.Activities version 2.6.2. Exited UI Studio,

Started UiPath Studio again, and then searched for and re-added the package. After then creating a fresh workflow, with just the Excel Application Scope , targeting a simple excel file stored on my documents file the same error occurs when I run the application.

Do you have any other suggestions?

Regards,
Shaun

Upgraded today to UiPath.Excel.Activities 2.6.3 . Same error still occuring, any ideas as I would really like to continue to learn.

I don’t know whether this is going to help or not @Shaun_Lockwood, But restarting the machine will help in this kind of situations :slight_smile:

Can you try once

Hi @HareeshMR,

I gave that a shot after unstinstalling Office 365, did a reboot prior to reinstalling Office.

Also tried that when I un-installed UI Path.

Even tried a registry clean with CC-Cleaner program and some other solutions suggested ensuring certain registry keys had the correct version of Office so even edited the registry to ensure the number was correct - 1.9 from memory.

I am at loss on what to try next.

I am on the same boat. Need help!

@Shaun_Lockwood Did you ever solve this issue ?
Im in the same pain with Office 365 ProBlus

Can you try using another two activities which are available in System>File>Workbook?

Yes activities in System>File>Workbook works.

My concern is that my office laptop works fine with Excel scope activities and it should be the same windows image installation that is performed on both my desktop and laptop office PC’s (it should be)
although that…

Desktop, office365 version is 64 bit - which is not working with Excel scope.
Laptop, office365 version is 32 bit - works fine with both.

Would you recommend always using System>File>Workbook instead of Excel scope, for more stable robot ? (here i’m thinking about if i share my bot in future)