Excel Application Error. Error opening workbook. Make sure excel is installed

Hi All;

I’ve seen this issue posted by others but, I decided to post a different thread.
The source of the error is the Excel Application Scope.
I’ve tried the following actions (no success):
1 - Remove the MS-Office and re-install it
2 - Check the regedit keys for 64 bits
3 - Try to open excel directly from its directory ("“C:\Program Files\Microsoft Office\root\Office16\EXCEL.EXE”) - I used this path directly in the UIPath and it returns an error. At the command prompt line in Windows 10, it works.

Any solution to this? I am try to execute the excel examples and do some work on excel.

Regards,

Ethienni

Hi @ethienni
Welcome to the community forum!

Could you post a screenshot of your workflow?

Hi,

Here you have the screenshot. It is a very basic action - to start the excel.

Regards,
Ethienni

You need to select just excel path in Excel scope application

How do I do that? How do I select just the excel path in the scope application?
The path I’ve posted (in the picture) is exactly the Excel path in my computer.

Regards,

Ethienni

@ethienni

You have to pass Excel file path but not EXE path.

1 Like

Hi,

I did that. I’ve tried with several different Excel files and it is not working.
I already removed the Office365 and re-installed it and still, not working.
I have updated the packages related to the excel.
Is there anything else I can do?

Regards,

Ethienni

1 Like

Actually the Excel Application scope activity takes the excel file path and not the excel application path and there is a huge difference between them dude.
That is
the excel file path will be like this
"C:\yourfolderpath\yourexcelfilename.xlsx"
or
"C:\yourfolderpath\yourexcelfilename.xls"

while the one you have mentioned is excel application file path
"C:\Program Files\Microsoft Office\root\Office16\EXCEL.EXE”
That makes the difference buddy

so we need to pass the file path and not the application exe path…
–and make sure that we have excel installed in our system when we are using this activity excel application scope

Hope this would help you
Kindly try this and let know for any queries
cheers @ethienni

Hi “dude”,

As I told you, I tried the path with some excel files including the file “C:\myfolder\Exam results.xlsx” that is one of the examples provided in the UIPath academy.
I am a computer engineer so, I know the difference between the excel.exe and the file path - the problem does not lie there. The issue is that the UIPath is not invoking the Excel as it should. I saw many other people raising this issue in the forums and I tried their approach (re-installing MS-Office and other items). Nothing is working, in my case.
I am 100% percent sure that Excel is installed in my system - I did installed and re-installed it a couple of times.
Is there any other option that I can try?
Attached to this, you’ll find a screenshot.

Regards,

Ethienni

Hi @ethienni “dude”

Firstly I just want to say that your attitude is totally wrong. Every here are computer engineers also and we are only trying to help each other, maybe your first screenshot was copy/paste mistake or something else and people might thing that you over looked that and I repeat they are just trying to help.

On another topic, You can try one of this options maybe it will help you with “It is a very basic action - to start the excel.”:

  • reinstall packages in UiPath
  • “start process” activity and pass path to your .exe file
  • “invoke Power Shell” activity and pass and pass path to your .exe file ( if you have blank space in your path you might want to use it like ‘yourPath’ )

cheers!

Hi, @Nikola_Drazic “dude”

Thanks for the input. I know we are all trying to help each other. I am just showing my perspective.
All help is welcome - I am just trying to get the attention from the UIPath engineers/support.
About your suggestion is interesting and worked - I was able to open the excel. Thanks!
I just don’t know why it doesn’t work with the “Excel Application Scope”.
Any other suggestions?

Thanks,

Ethienni

Hi All,

Just to summarize what I have so far and share with you all:
1 - For some reason, I can’t open and use the Excel through the “Excel Application Scope” activity. It gives me back the error: “Error Opening the workbook. Make sure excel is installed”.
2 - I saw that other forum members had the same issue and they suggested to reinstall the MS-Office, edit the regedit (if you have mixed 32-bit and 64-bits keys in the regedit for the typelib). It didn’t work for me.
3 - I followed the suggestion of @Nikola_Drazic, and used the activity “Start Process” and include the path for the Excel Application (“C:\Program Files\Microsoft Office\root\Office16\EXCEL.EXE” - in my case). It worked fine. This can be a workaround if you need to open Excel and read its contents.

But, the original problem of starting excel using the “Excel Application scope” activity is not solved. I just curious if it is a bug or something else that I need to look into.
All suggestions that could help are welcome.

Regards,

Ethienni

Hi @ethienni

I think that answer is not that simple and that you have to do some serious investigation. Here are some questions from me that can have affect on your problem:

  • is that domain or workgroup machine?
  • do you know of which groups that machine is member?
  • is this user: user, local admin, domain admin?
  • who is owner of those programs?
  • which version of UiPath are you using? Are you on beta channel?
  • which version of MS Office are you using? Was there some patch through Window update?
    was there some cumulative update?
  • is this isolated case? did you noticed similar stuff on another machine?
  • is UAC turned on or off?

I would start from these questons and also I would include UIPath support. For now we gave you advice and help you a little so you can continue with your work.

Cheers and welcome to the community forum!

Thanks, @Nikola_Drazic.
In fact, I need to do some investigation. It is not working, yet.
I’ll reach out to support and I’ll you let you know when I get some solution.

Regards,
Ethienni