Excel Application Error. Error opening workbook. Make sure excel is installed

Hi All;

I’ve seen this issue posted by others but, I decided to post a different thread.
The source of the error is the Excel Application Scope.
I’ve tried the following actions (no success):
1 - Remove the MS-Office and re-install it
2 - Check the regedit keys for 64 bits
3 - Try to open excel directly from its directory ("“C:\Program Files\Microsoft Office\root\Office16\EXCEL.EXE”) - I used this path directly in the UIPath and it returns an error. At the command prompt line in Windows 10, it works.

Any solution to this? I am try to execute the excel examples and do some work on excel.



1 Like

Hi @ethienni
Welcome to the community forum!

Could you post a screenshot of your workflow?


Here you have the screenshot. It is a very basic action - to start the excel.


You need to select just excel path in Excel scope application

How do I do that? How do I select just the excel path in the scope application?
The path I’ve posted (in the picture) is exactly the Excel path in my computer.




You have to pass Excel file path but not EXE path.

1 Like


I did that. I’ve tried with several different Excel files and it is not working.
I already removed the Office365 and re-installed it and still, not working.
I have updated the packages related to the excel.
Is there anything else I can do?



1 Like

Actually the Excel Application scope activity takes the excel file path and not the excel application path and there is a huge difference between them dude.
That is
the excel file path will be like this

while the one you have mentioned is excel application file path
"C:\Program Files\Microsoft Office\root\Office16\EXCEL.EXE”
That makes the difference buddy

so we need to pass the file path and not the application exe path…
–and make sure that we have excel installed in our system when we are using this activity excel application scope

Hope this would help you
Kindly try this and let know for any queries
cheers @ethienni

Hi “dude”,

As I told you, I tried the path with some excel files including the file “C:\myfolder\Exam results.xlsx” that is one of the examples provided in the UIPath academy.
I am a computer engineer so, I know the difference between the excel.exe and the file path - the problem does not lie there. The issue is that the UIPath is not invoking the Excel as it should. I saw many other people raising this issue in the forums and I tried their approach (re-installing MS-Office and other items). Nothing is working, in my case.
I am 100% percent sure that Excel is installed in my system - I did installed and re-installed it a couple of times.
Is there any other option that I can try?
Attached to this, you’ll find a screenshot.



Hi @ethienni “dude”

Firstly I just want to say that your attitude is totally wrong. Every here are computer engineers also and we are only trying to help each other, maybe your first screenshot was copy/paste mistake or something else and people might thing that you over looked that and I repeat they are just trying to help.

On another topic, You can try one of this options maybe it will help you with “It is a very basic action - to start the excel.”:

  • reinstall packages in UiPath
  • “start process” activity and pass path to your .exe file
  • “invoke Power Shell” activity and pass and pass path to your .exe file ( if you have blank space in your path you might want to use it like ‘yourPath’ )


Hi, @Nikola_Drazic “dude”

Thanks for the input. I know we are all trying to help each other. I am just showing my perspective.
All help is welcome - I am just trying to get the attention from the UIPath engineers/support.
About your suggestion is interesting and worked - I was able to open the excel. Thanks!
I just don’t know why it doesn’t work with the “Excel Application Scope”.
Any other suggestions?



Hi All,

Just to summarize what I have so far and share with you all:
1 - For some reason, I can’t open and use the Excel through the “Excel Application Scope” activity. It gives me back the error: “Error Opening the workbook. Make sure excel is installed”.
2 - I saw that other forum members had the same issue and they suggested to reinstall the MS-Office, edit the regedit (if you have mixed 32-bit and 64-bits keys in the regedit for the typelib). It didn’t work for me.
3 - I followed the suggestion of @Nikola_Drazic, and used the activity “Start Process” and include the path for the Excel Application (“C:\Program Files\Microsoft Office\root\Office16\EXCEL.EXE” - in my case). It worked fine. This can be a workaround if you need to open Excel and read its contents.

But, the original problem of starting excel using the “Excel Application scope” activity is not solved. I just curious if it is a bug or something else that I need to look into.
All suggestions that could help are welcome.



Hi @ethienni

I think that answer is not that simple and that you have to do some serious investigation. Here are some questions from me that can have affect on your problem:

  • is that domain or workgroup machine?
  • do you know of which groups that machine is member?
  • is this user: user, local admin, domain admin?
  • who is owner of those programs?
  • which version of UiPath are you using? Are you on beta channel?
  • which version of MS Office are you using? Was there some patch through Window update?
    was there some cumulative update?
  • is this isolated case? did you noticed similar stuff on another machine?
  • is UAC turned on or off?

I would start from these questons and also I would include UIPath support. For now we gave you advice and help you a little so you can continue with your work.

Cheers and welcome to the community forum!

Thanks, @Nikola_Drazic.
In fact, I need to do some investigation. It is not working, yet.
I’ll reach out to support and I’ll you let you know when I get some solution.


Hi @ethienni,
Even i’m facing the same issue, as @Nikola_Drazic’s advice i was able to open excel using start process but not able to write in the file using write cell in Excel application scope. Again it is trying to open Excel and gave me the same error “Error Opening the workbook. Make sure excel is installed. please help me to get this



Thanks for reaching out. I hope I can point you in the right direction.

I don’t think I have the solution but, there are some items you need to check that probably will give you a workaround, at least.

First, the MS Excel that I am using on my computer is part of the Office 365 package. As per my research, Office 365 doesn’t entirely install Excel on your computer. I guess it installs some modules, and your computer interacts with components that are online on the Microsoft Cloud. I am not a Microsoft Engineer; they can explain to you better the installation and architecture of components in your machine. I guess that is missing some DLLs (Dynamic Link Libraries) that are needed for UIPath to work with Office 365. Please, check if your Excel is part of an Office 365 package. A direct way to know if your Excel is locally installed is to know if Excel is part of the Office 2013, Office 2016, or Office 2019. If you have one of these versions, you have a locally installed Excel.

  1. If your Excel is a not part of Office365, then you can perform some troubleshooting:

1.1 – Check about the version: 32 bits or 64 bits. There is a good discussion about it in this forum (link here: Error opening workbook. Make sure Excel is installed - #10 by Yumwzsch)

1.2 – Update the UIPath packages to the latest version and restart the machine

1.3 – Make sure you the “Excel Activities” package installed. You probably have, make sure.

1.4 – If nothing from the above solves it, try to re-install the office, using the MS Office Installation software (link here: Download and install or reinstall Microsoft 365 or Office 2021 on a PC or Mac)

  1. Now, if your case is related to Office 365, then I am sorry to say that I found no solution. I installed the Office 365 package on UIPath, and it didn’t work. There some things you can try:

2.1 – You can install the Office 2016 or Office 2019 on a different computer and run your UIPath workflows on this new machine.

2.2 – One thing that worked for me was to create a virtual machine on the Amazon Cloud (AWS) with the software I needed. They have a service called “Workspaces.” I installed a Windows machine with Office 2016 and UIPath. Then, I ran the flow from there. In this machine, Excel works fine. I don’t know how practical this will be to you, but you can run the workflows in the spare machine and export the results to the client machine.

As I wrote in the beginning, I don’t have a direct solution. You have some tracks to investigate, and I hope you find your way around.

Please, after you find a solution, give us some feedback about what you did because this is a learning forum. We are in the same boat, mate.

Cheers and good luck,


1 Like

Hello people!

I just have solved this problem by repairing office instalation directly from control panel. I have office 2016 installed, and it was working fine with uipath till today, when I was running some bots for testing, and Uipath gave me the same error. After doing some changes like I had read in this and other forums without results, I try to Repair the instalation using the control panel and tit worked fine!, Now I am using UiPath with excel again.

I had same problem. Using Studio community ( version 2020.4.1) project using UiPath.Excel.Activities = 2.8.5 only Office 365 (64bit) installed. It turned out when I was not signed-in to microsoft/office I was getting the (TYPE_E_CANTLOADLIBRARY) error… Once I signed it worked fine.

Maybe UIPath could detect this specific case better and provide a more useful log message.

@ ethienni

I am also facing same issue and searching over resolution over forum since last year but couldn’t find any satisfactory response.

Definitely it will work if you have ms-office 2016 and any advance office version. But my concern is why its not working on any excel version?

I have Ms-office 2010 and Windows 64-bit OS but i am getting error for Excel application scope.

I think UI Path should happily accept this as bug and should work on this else all thing your are tying to implement is waste of money if you don’t resolve simple excel file opening issue.


Thanks for reaching out. This issue is very annoying, indeed.
I have an update: because I had to update my notebook, I reinstalled only windows 10 and Uipath in the old machine. I was having the issue with uipath and the Excel in this old machine. after reinstalling windows 10 and uipath, it worked! Even Office365 Excel is working!
So, I guess that there was some application (other app) that was using 32-bit architecture and it was messing up with the Excel… I know that is a nightmare to reinstall everything from zero but, if you have no other solution, this could be a way.
I hope it helps.