Excel application scope Error opening workbook. Make sure Excel is installed

Hi Experts,

This issue has been discussed many times on the forum but non of them are working for me.

If I keep excel open before running the process then it is working fine but if I close the excel and try to run, it fails.

Solutions Tried
1. Re-installing Office
2. Tried 32bit and 64 bit office
3. Tried with different versions of Excel Activity
4. Tried with and without Visible option

Please help.


Sounds awful. Any chance you could share the Wf with a small sample excel file so we can investigate why this keeps happening?
Also, some details on the operating system would help. Im guessing youre running a Windows 64 bit? Which Version: 7, 10 Pro /10 Enterprise.


1 Like

Hello @thepathbreaker,

paste/attach error that you have been facing when you run this script.


Hi @Ciprian_Forcos,

I am using Windows 8.1 Pro 64 bit.

Main.xaml (7.2 KB)


so the wf works ONLY if you have an excel workbook already opened?

Yes… any Excel workbook even if it is an empty one.

Hello Team,

Any solution??


Dear Thepathbreaker,

If you need to have excel open when you use the activity simply invoke a Start Process or Open Application activity before Excel Application Scope, as an workaround.

In the mean time, could you please check event viewer logs and paste here the error?

Bogdan Coman

Hi @Pankaj.Patil,

Here is the screenshot.


Hi @Bogdan_Coman,

This is the one you are asking for??

Log Name: Application
Source: UiPath
Date: 23-04-2018 12:27:32
Event ID: 0
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer: ELT003
{“message”:“Execution failed received for : 2010bc94-28ab-4ccf-ae77-36850a8e35c8, Error”,“level”:“Error”,“logType”:“Default”,“timeStamp”:“2018-04-23T12:27:32.3370171+05:30”,“fingerprint”:“e0ab8a52-630c-4fcc-97a7-75ec7d4e6183”}
Event Xml:

    <Provider Name="UiPath" />
    <EventID Qualifiers="0">0</EventID>
    <TimeCreated SystemTime="2018-04-23T06:57:32.000000000Z" />
    <Security />
    <Data> {"message":"Execution failed received for : 2010bc94-28ab-4ccf-ae77-36850a8e35c8, Error","level":"Error","logType":"Default","timeStamp":"2018-04-23T12:27:32.3370171+05:30","fingerprint":"e0ab8a52-630c-4fcc-97a7-75ec7d4e6183"}</Data>

Dear Thepathbreaker,

It seems like you have some problems with excel 64-bit version because is trying to load 32-bit DLL. Please check this post.

Bogdan Coman

Hello @thepathbreaker,

Please go through below link,

Let us know updates :slight_smile:


Hi @Pankaj.Patil

Tried both but in vain.


Thanks @Bogdan_Coman

Let me try it

go to MicroSoft office 365 and there you will see a option to repair .
please repair your 365 ,it will take some time.
then it should work.
because even i tried everything but only this could solve it


FIXED! by doing a office repair (go to add/remove programs, click on your office version> Change> do a quick repair. If not fixed, do an online repair.)


Still on this issue… repairing did not fix the problem. Any other workarounds available?

try this:
reference: https://help.innowera.net/PR2008/2.00/index.htm?resolve_type_e_libnotregistered_error.htm