Libraries to Orchestrator

Hi Team,

I created a library and published into orchestrator. But i am unable to view it in orchestrator LIBRARIES menu. Kindly provide your inputs

Regards,
Bala

Hi @Robotics

What is your version of Orchestrator?

Hi,

Its 2019.4.0-CE.22.

Okay, for our Orchestrator CE it should be simple enough. Could you check your Orchestrator options? :slight_smile:

If you go to Settings -> Deployment, you will be able to switch your libraries feed to Tenant instead of Host. This should fix it, I hope :slight_smile:
image

1 Like

Hi,

Thanks i am able to upload my library into orchestrator now. I have few more clarifications. Wanted to know the main purpose of using this libraries. My understanding is (correct me if i am wrong)

  1. Creating my own library(locally) and uploading it into the orchestrator.
  2. Whichever the bots are in need of this library will invoke it and reuse the components in it.
  3. If above 2 points are true, then whats the difference between Version Control and Libraries.
  4. More importantly what other benefits/features present in libraries ?

Hi @Robotics

I’m glad your issue is resolved. In short, the Library project that you publish is turned in an activity package you need to install. Each XAML file from that project will become an activity you can then drag and drop to your other projects. You can specify in and out arguments for such an activity and then simply pass them via Properties, as you would do with any other activity.

This makes your life simpler, as you can separately maintain your Library process (and activities it contains).

Version Control repositories are meant to track changes in your projects (be it a normal workflow project or a library project). Nothing stops you from keeping your Library project in the Version Control repository to keep track of its changes :slight_smile:

Ok, got it. Thanks. Now i am able to upload my library and 1 process which invokes the library.

  1. Library just contains just a Write Line “Welcome 1”
  2. Process contains three lines first line which calls the above library second line contains Write Line “Welcome 2” and third line again calls the library.
  3. So my output should be
    Welcome 1
    Welcome 2
    Welcome 1

Now i am running this process from orchestrator
My question is where i need to see the output ?

Thanks again for your inputs

Hi @Robotics

This would be about the difference between the Write Line and the Log Message. If you want your logs to show in Orchestrator, please use the Log Message activity :slight_smile:

Great it works fine :+1: :slight_smile: have one more question. :slight_smile:

Now i modified my library in my local pc and trying to run it locally from my process.xaml
but the newly appended changes in library not getting reflected. Can you provide me the steps to see the changes locally?

If you want to modify the library source code, you will need to republish it for it to take effect.

Yes its fine now. My library is not at all called while running from orchestrator.

  1. I have published my process into orchestrator which calls the library
  2. Published library into orchestrator. Library contains just a message box.
  3. When running the process from orchestrator this msg box in library not displayed.
  4. Is there is any restriction that should not place a msg box inside the library ?

I suppose it displays properly when you run the process in Studio during development?

Thanks for your support, it works fine. :+1:

1 Like

Hi, I’ve tried this option but still not able to publish the library to the orchestrator

Hi @Karthiga

Welcome back! :slight_smile:

What is the error that you are getting?